
  


<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="https://www.idahocountyfreepress.com/content/tncms/live/" />
<meta name="keywords" content="regional" />
<meta name="news_keywords" content="regional" />
<meta name="description" content="Jeff Greene received a personal visit from some very important folks from the Special Olympics Idaho who had traveled long and far through the windstorm on Jan. 13, to officially" />
<meta name="author" content="" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta name="googlebot" content="noarchive" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.idahocountyfreepress.com/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=800%2C580" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="580" />
<meta property="og:title" content="Resident from Peck, Idaho to participate in 2022 Special Olympics" />
<meta property="og:description" content="Jeff Greene received a personal visit from some very important folks from the Special Olympics Idaho who had traveled long and far through the windstorm on Jan. 13, to officially" />
<meta property="og:site_name" content="Idaho County Free Press" />
<meta property="og:section" content="Regional News for Idaho and the Pacific Northwest" />
<meta property="article:publisher" content="https://www.facebook.com/idahocountyfreepress/" />
<meta property="tncms:subs" content="2.0" />
<meta property="tncms:ads" content="smart,lazyload,refresh" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.031dcc667e016ff03515695a78b3a2c8.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.0740431ec2aa31f2e7d813ea5c660a8d.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Open+Sans|Sura:300,400,700"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-button.52347555fbb6668223efabadb9c9d111.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-utility-promo-designer.59905c960650c756bd917d9e081675c9.css"/>
<link rel="stylesheet" href="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/styles/tnt.comments.c281ededc640381d48e91e027585814d.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/styles/flex-classifieds-bulletins.a78f8be1f6e0dabcb5acb9a8939501f8.css"/>
<style>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</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"mobile_pattern","style":"default","path":"\/news\/regional","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"true"},"vendor":{"outbrain":"Headlines and photo grid","taboola":""},"system":{"render_time":410},"client":{"is_bot":"no","is_gdpr":"no"},"asset":{"id":"b3d8ee22-6286-11eb-82b1-43c8a113ada8","app":"editorial"},"google":{"ua":"UA-52905808-1"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://tags.crwdcntrl.net/c/13590/cc.js?ns=_cc13590" id="LOTCC_13590"></script>
<script>
	if(document.cookie.indexOf('tncms-dmp-id') != -1) {
		_cc13590.add('tp', 'TNNW');
		_cc13590.add('act', ' User Login');
		_cc13590.add('tpid', document.cookie.split( ';' ).map( function( x ) { return x.trim().split( '=' ); } ).reduce(function( a, b ) { a[ b[ 0 ] ] = b[ 1 ]; return a; }, {} )[ "tncms-dmp-id"]);
		document.cookie = 'tncms-dmp-id=;expires=Thu, 01 Jan 1970 00:00:01 GMT';
		sessionStorage.removeItem('tncms.behaviors');
		sessionStorage.removeItem('tncms.dmp.audiences');
	}
	_cc13590.bcp();
</script>

<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms/subscription.js"></script>
<script>/*<![CDATA[*/ TNCMS.Subscription.initialize({"service_id": "3788,3140,2840,3069,2692,2828,2811", "prefix": ""}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/subscription/resources/scripts/tnt.access.status.828de94349981272665c0fb0107f3e49.js"></script>
<script>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</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/user-controls.578df3df79d812af55ab13bae47f9857.js"></script>
<script src="https://tagan.adlightning.com/townnews/op.js"></script>
<script async="async" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script>/*<![CDATA[*/ window.googletag = window.googletag || {cmd: []};
    window.gptAdSlots = window.gptAdSlots || [];

    window.__tnt = window.__tnt || {};
    __tnt.ads = __tnt.ads || {};
    __tnt.ads.dfp = __tnt.ads.dfp || {};
    __tnt.ads.dfp.dmp = __tnt.ads.dfp.dmp || {};
    __tnt.ads.dfp.dmp.audienceCheck = function(settings) {
        if (!__tnt.client.capabilities.supportsLocalStorage() || localStorage.getItem('tncms.dmp.audiences') == null) return false;
        if (settings.block && typeof settings.audience != 'undefined' && settings.audience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), settings.audience.split(','))) return true;
        } else if (typeof __tnt.ads.dfp.dmp.hideAudience != 'undefined' && __tnt.ads.dfp.dmp.hideAudience.length > 0) {
            if (__tnt.compareArray(JSON.parse(localStorage.getItem('tncms.dmp.audiences')), __tnt.ads.dfp.dmp.hideAudience)) return true;
        }
        return false;
    };

    __tnt.ads.dfp.targeting = __tnt.ads.dfp.targeting || {};
    __tnt.ads.dfp.targeting.k = ["regional"];

    __tnt.ads.dfp.targeting.page = ["asset","article","app-editorial"];
    __tnt.ads.dfp.templates = __tnt.ads.dfp.templates || {};
    __tnt.ads.dfp.templates = {
        interstitial:"https:\/\/bloximages.newyork1.vip.townnews.com\/idahocountyfreepress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/interstitial.7047e23fde50ef7dc7625903de95abec.js",
        nativeArticle:"https:\/\/bloximages.newyork1.vip.townnews.com\/idahocountyfreepress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/native-article.9b3cd3bb8591bed71346f4fe429b96dc.js",
        pageCurl:"https:\/\/bloximages.newyork1.vip.townnews.com\/idahocountyfreepress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/page-curl.ca0c1a7372c29272ef1ccf504ced01a9.js",
        parallax:"https:\/\/bloximages.newyork1.vip.townnews.com\/idahocountyfreepress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/parallax.0ce32932f3b4125f930bea8d431f8f03.js",
        paw:"https:\/\/bloximages.newyork1.vip.townnews.com\/idahocountyfreepress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/paw.f2c3f73025b675e671c97fb411b2228d.js",
        pencil:"https:\/\/bloximages.newyork1.vip.townnews.com\/idahocountyfreepress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/pencil.7d33f5d95dc0b3cd3fe8f11229d905ca.js",
        reveal:"https:\/\/bloximages.newyork1.vip.townnews.com\/idahocountyfreepress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/reveal.e5d561a6b71aa2730a07fa90f5f4f6d6.js",
        stickyAnchor:"https:\/\/bloximages.newyork1.vip.townnews.com\/idahocountyfreepress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/sticky-anchor.6dc181cbc3d60e2a1892d05998349ef6.js",
        video:"https:\/\/bloximages.newyork1.vip.townnews.com\/idahocountyfreepress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/video-inline.9b0997ab77d1d69707d283848faeacdd.js",
        wallpaper:"https:\/\/bloximages.newyork1.vip.townnews.com\/idahocountyfreepress.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/ads_dfp\/resources\/scripts\/templates\/wallpaper.dc1c1bace62343a130be3589fe0846f9.js"
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/idahocountyfreepress.com/news/regional';
            
                gptAdSlots['ad-1015379'] = googletag.defineSlot(adUnit, [2,1], 'ad-1015379').setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1015379'].setTargeting('pos', ['impact-top']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/idahocountyfreepress.com/news/regional';
            var mapping = googletag.sizeMapping().addSize([320, 0], [320, 50]).addSize([768, 0], [[728, 90], [320,50]]).addSize([992, 0], [[970, 90], [728, 90], [970, 250]]).addSize([1200, 0], [[970, 90], [728, 90], [970, 250], [1170, 90]]).build();
                gptAdSlots['ad-1015370'] = googletag.defineSlot(adUnit, [[320,50],[728,90],[970,90],[970,250],[1170,90]], 'ad-1015370').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1015370'].setTargeting('pos', ['leaderboard-one']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/asset/resources/scripts/tnt.nextPrev.f1660ccf5d097410b8b72737d216878c.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/vendor.taboola.0f7d1c50406b868f466f9143671a50f4.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.comment.ab5fb87419367af823185ae92fe15663.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.emoticons.2048520c3a5ad423f37d8d4ac8c790a9.js"></script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/idahocountyfreepress.com/news/regional';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300, 250], [320,50]]).addSize([768, 0], [[300, 250], [320,50]]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-1015371'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-1015371').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1015371'].setTargeting('pos', ['rectangle-one']);
    });
 /*]]>*/</script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/ie.grid.placement.8d31e32afeebe4520bfab9638ef91435.js"></script>
<script>/*<![CDATA[*/ window.bulletins_config || (window.bulletins_config = []); window.bulletins_config.push({"asset_title":"hover","bg_color":"#dfdfdf","columns":"2","heading_tag":"h2","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","display_width":"region","bottom_margin":"standard","block_bg_color":"","block_id":"685879"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/idahocountyfreepress.com/news/regional';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300, 250], [320,50]]).addSize([768, 0], [[300, 250], [320,50]]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-1015373'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-1015373').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1015373'].setTargeting('pos', ['rectangle-two']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/132916964/idahocountyfreepress.com/news/regional';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[300, 250], [320,50]]).addSize([768, 0], [[300, 250], [320,50]]).addSize([992, 0], [[300, 250], [300,600]]).addSize([1200, 0], [[300, 250], [300,600]]).build();
                gptAdSlots['ad-1015375'] = googletag.defineSlot(adUnit, [[300,250],[320,50],[300,600]], 'ad-1015375').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-1015375'].setTargeting('pos', ['rectangle-three']);
    });
 /*]]>*/</script>
<script>/*<![CDATA[*/ window.promo_design_config || (window.promo_design_config = []); window.promo_design_config.push({"bg_color":"#ffffff","button_size":"btn-lg","button_style":"primary","button_text":"Subscribe today","button_url":"https:\/\/www.idahocountyfreepress.com\/site\/forms\/subscription_services\/","card_shape":"rectangle","content_text":"Local news sources need your help. As a subscriber you'll stay in the know and help us continue our mission to keep the community informed.","content_text_color":"dark","content_text_shadow":"disabled","display_again":"4","display_triggers":"exit_intent","display_width":"region","headline_shadow":"disabled","headline_size":"large","headline_text":"Help support your local news","headline_text_color":"dark","image_display":"large","info_text_color":"light","lead_in":"Your support is needed now more than ever","lead_text_color":"dark","lead_text_shadow":"enabled","outline_color":"#ff0000","overlay_action":"centered","sticker_icon":"newspaper-o","sticker_shape":"circle","utm_campaign":"pop_up","utm_campaign_content":"utility_promo_designer","utm_campaign_name":"subscribe_promo_exit_layover","utm_medium":"utility_promo_designer","utm_source":"blox","utm_tracking":"1","heading_tag":"h3","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","card_shadow":"enabled","border_width":"5","sticker_color":"#333333","sticker_icon_color":"white","info_text":"","info_text_shadow":"disabled","enable_email":"","require_user_account":"","signup_lists_only":"","list_ids":"","email_text_color":"dark","email_text_shadow":"disabled","email_button_style":"default","sign_up_text":"Sign up","manage_button_text":"Manage your lists","display_timer":"","show_audience":"","hide_audience":"","block_id":"893601"}); /*]]>*/</script>
<script>/*<![CDATA[*/ 
    googletag.cmd.push(function(){
            var adUnit = (window.frameElement && window.frameElement.getAttribute('data-gam-adunit')) ? window.frameElement.getAttribute('data-gam-adunit') : '/22630788/bottompagecling';
            var mapping = googletag.sizeMapping().addSize([320, 0], [[320, 50],[300,250]]).addSize([768, 0], [728,90]).addSize([992, 0], [728,90]).addSize([1200, 0], [728,90]).build();
                gptAdSlots['ad-731045'] = googletag.defineSlot(adUnit, [[320,50],[300,250],[728,90]], 'ad-731045').defineSizeMapping(mapping).setCollapseEmptyDiv(true).addService(googletag.pubads());
                gptAdSlots['ad-731045'].setTargeting('pos', ['block-sticky-anchor']);
    });
 /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>
<script>/*<![CDATA[*/ 

    googletag.cmd.push(function() {
        googletag.pubads().setTargeting('browser', __tnt.client.browser.name);
        if (__tnt.ads.dfp.targeting) {
            for (var k in __tnt.ads.dfp.targeting) {
                if (__tnt.ads.dfp.targeting.hasOwnProperty(k)) {
                    googletag.pubads().setTargeting(k,__tnt.ads.dfp.targeting[k]);
                }
            }
        }
            googletag.pubads().disableInitialLoad();
            googletag.pubads().addEventListener('impressionViewable', function(event) {
                for (var key in gptAdSlots) {
                    if (gptAdSlots[key] === event.slot && __tnt.ads.slots[key]) {
                        if (!__tnt.ads.slots[key].viewableImpression) __tnt.ads.slots[key].viewableImpression = true;
                    }
                }
            });

        googletag.pubads().enableSingleRequest();
        googletag.enableServices();
    });
 /*]]>*/</script>

            
            <title>Resident from Peck, Idaho to participate in 2022 Special Olympics | Regional News | idahocountyfreepress.com</title>
            
    <style>body { background-color: #ffffff; color: #333333; }a, a:hover, .pagination>li>a, .pagination>li>a:hover, .btn-link, .dropdown-menu>li>a, blockquote, blockquote p, .asset .asset-body blockquote p { color: #4175aa; } #main-body-container .container, #main-body-container .container_fluid, .well-main { background-color: #ffffff; } .tnt-content-width-container > * { max-width: 1140px; margin-left: auto; margin-right: auto; } #site-navbar-container, #main-navigation { background-color: #fff; } .fixed-nav #main-navigation { background-color: #fff !important; } #site-top-nav-container, #site-top-nav { background-color: #000; } #site-footer-container, #site-footer { background-color: #000; color: #fff; } .navbar-default .navbar-nav>li>a, .navbar-default .navbar-nav>li>a:hover, .navbar-default .navbar-nav>li>a:focus, .navbar-default .navbar-nav>.open>a, .navbar-default .navbar-nav>.open>a:hover, .navbar-default .navbar-nav>.open>a:focus { color: #000; } .navbar-toggle .icon-bar { background-color: #000 !important; } .navbar-toggle .sr-only-show { color: #000 !important; } #site-top-nav .list-inline>li>a { color: #fff; } .asset .asset-body p, .asset #asset-content p { color: #444; } #site-header-container { background-color: #ffffff; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }/* full span block region */ #main-top-container.container-fullscreen-region.container-fluid { padding-left: 0px !important; padding-right: 0px !important; }@media (max-width: 991px){ .navbar-default .navbar-nav .open .dropdown-menu>li>a, .navbar-default .navbar-nav .open .dropdown-menu>li>a:hover, .navbar-default .navbar-nav .open .dropdown-menu>li>a:focus { color: #000; } }#site-copyright a, #site-footer a { color: #fff; } /* CSS has moved to Site templates/Global skins/flexsystem/resources/site.css.inc.utl */ </style> <!-- site.css.inc.utl has been included. --> <!-- NOTE: anything in an include file, outside of UTL tags , will be output on the page --> <style> /* Place site-wide CSS here */ /* BASE STYLES */ html {font-size:10px;} body {font-family:'Open Sans', sans-serif;} .btn {transition:all .25s ease-in-out;} .btn-primary {background-color:#222; border-color:#222;} .btn-primary:hover, .btn-primary:focus {background-color:#000; border-color:#000;} .btn-warning {background-color:#FFCE34; border-color:#FFCE34;} .btn-warning:hover, .btn-warning:focus {background-color:#D8B02B; border-color:#D8B02B;} .btn-success {background-color:#275B33; border-color:#275B33;} .btn-success:hover, .btn-success:focus {background-color:#1F4929; border-color:#1F4929;} .btn-danger {background-color:#BD2106; border-color:#BD2106;} .btn-danger:hover, .btn-danger:focus {background-color:#980901; border-color:#980901;} .label-primary {background-color:#222; border-color:#222;} .label-warning {background-color:#FFCE34; border-color:#FFCE34;} .label-success {background-color:#275B33; border-color:#275B33;} .label-danger {background-color:#BD2106; border-color:#BD2106;} .nav-pills>li.active>a, .nav-pills>li.active>a:focus, .nav-pills>li.active>a:hover {background-color:#000;} .progress-bar {background-color:#275B33;} .custom-left{width: 130px;float:left;} .custom-right{width: 130px;float:right;} /* HEADER STYLES */ .a img {width:100%;} .header-weather, .header-user, .header-search {padding:7px 10px;} .header-weather .open a, .header-user .open a, .header-search .open a {background:rgba(0,0,0,0);} .header-search .tnt-search {color:#fff;} #main-navigation a {font-family:'Sura', serif; text-transform:uppercase;} #main-nav_menu >li >a {padding:15px 10px;} /* BODY STYLES */ .block-title {border-bottom:2px solid black; position:relative; top:-2rem;} .block-title-inner {position:relative; top:2.5rem; background:white; margin-left:3rem; padding:10px!important;} .block-title-inner a {color:#000;} .block-title-inner h3 {font-family:'Sura', serif; font-size:2.5rem; text-transform:uppercase;} .block-title-inner h4 {font-family:'Sura', serif; font-size:2rem; text-transform:uppercase; position:relative; top:-0.2rem;} .card.feature .centered-content-container.vert-align-bottom.text-left .centered-content {max-width:100%;} #block-685982 .block-title-inner {margin-left:0;} #block-685982 .block-title-inner a {font-size:1.6rem;} /* FOOTER STYLES */ footer .block-title {border-bottom:2px solid white;} footer .block-title-inner {background:black!important;} .promo-designer-modal .close {color: #fff; opacity: .75;} .asset .exchange-source{display: none} /* Support Local Journalism - Christine */ .tnc-overlay .promo-design button.close { opacity: 1; color:#FFFFFF; } </style>
    
        <link rel="shortcut icon" type="image/x-icon" href="https://www.idahocountyfreepress.com/content/tncms/site/icon.ico" />
    
        <link rel="preconnect" href="//www.google.com">
    
        <link rel="preconnect" href="//adservice.google.com">
    
        <link rel="preconnect" href="//securepubads.g.doubleclick.net">
    
        <link rel="preconnect" href="//stats.g.doubleclick.net">
    
        <link rel="preconnect" href="//tpc.googlesyndication.com">
    
        <link rel="preconnect" href="//pagead2.googlesyndication.com">
    
        <link rel="preconnect" href="//tagan.adlightning.com">
    
        <link rel="preconnect" href="//s.yimg.com">
    
        <link rel="preconnect" href="//cdn.taboola.com">
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//bcp.crwdcntrl.net">
    
        <link rel="preconnect" href="//tags.crwdcntrl.net">
    <link rel="alternate" type="application/rss+xml" title="Resident from Peck, Idaho to participate in 2022 Special Olympics | Regional News | idahocountyfreepress.com" href="http://www.idahocountyfreepress.com/search/?f=rss&amp;t=article&amp;c=news/regional&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="https://www.idahocountyfreepress.com/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
             


        </head>
        <body class="app-editorial grid-mobile-pattern blox-asset uuid-b3d8ee22-6286-11eb-82b1-43c8a113ada8  section-news section-regional type-article infinity-disabled" data-path="/news/regional">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.idahocountyfreepress.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=mobile_pattern&amp;tncms.page.style=default&amp;tncms.page.path=%2Fnews%2Fregional&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=true&amp;tncms.vendor.outbrain=Headlines+and+photo+grid&amp;tncms.vendor.taboola=&amp;tncms.system.render_time=410&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.asset.id=b3d8ee22-6286-11eb-82b1-43c8a113ada8&amp;tncms.asset.app=editorial&amp;tncms.google.ua=UA-52905808-1&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
        
        
        
        
        <script>
            document.addEventListener("DOMContentLoaded", function(event) {
                __tnt.metering.access.d.push(function(){
                    //DMP logging
                    if(window._cc){
                        __tnt.log("Logging DMP data")
                        var paywallDmpData = 'Paywall : Viewed Paywall';
                        // Call to cms.dmp.js_behavior_action is here
                        _cc13590.add('act', paywallDmpData );_cc13590.bcp();
                    }
                });
            });
        </script>
    

    <div id="template-metering" data-message-mode="basic">
    <template class="template meter subscription">
        <div class="meter message" data-message="blox regissub subscription wall">
        <div class="wall panel panel-default">
            <div class="panel-body">
                <h4 class="meter-heading media-heading">
                    Thank you for reading!
                </h4>

                <p>Please purchase a subscription to read our premium content. If you have a subscription, please log in or sign up for an account on our website to continue.
</p>

                
                <div class="col-xs-12">
                    <div class="pull-right">
                        <a class="btn btn-default btn-block meter-modal-open">Purchase a Subscription</a>
                    </div>
                </div>
                
            </div>
        </div>
        </div>
</template>
    
    <template class="template meter registration">
        
    <div class="meter message wall panel panel-default" data-message="blox registration wall">
        <div class="panel-body">
            <h4 class="meter-heading media-heading">
                Thank you for reading!

            </h4>
            <p>Please <span class="not-logged-in">log in, or sign up for a new account</span> to continue reading.</p>

            <div class="col-xs-12">
                <div class="row not-logged-in">
                
                    <div class="col-xs-6">
                        
    <a  class="btn btn-default btn-block" href="https://www.idahocountyfreepress.com/users/signup/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">Sign Up</a>
                    </div>
                    <div class="col-xs-6">
                        
    <a class="btn btn-primary btn-block" href="https://www.idahocountyfreepress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">Log In</a>
                    </div>
                </div>
                
                <div class="row logged-in">
                    <a class="btn btn-default" href="https://www.idahocountyfreepress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.idahocountyfreepress.com%252Fnews%252Fregional%252Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%252Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">Purchase a Subscription
</a>
                </div>
            </div>
        </div>
    </div>
</template>
    
    <template class="template meter referred">
        <div class="meter notification referred alert alert-dismissable alert-info" data-message="blox user referred">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            Viewed <span class="count"></span> of <span class="total"></span>
            
        </h4>
         
        <p><strong>Thank you for reading!
</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
    
    <template class="template meter access" data-count="1">
        <div class="meter notification access alert alert-dismissable alert-info hidden-print" data-message="blox first free">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            Viewed <span class="count"></span> of <span class="total"></span>
            
        </h4>
         
        <p><strong>Welcome!</strong> We hope that you enjoy our free content.</p>
    </div>
</template>
    
    <template class="template meter access" data-count="2" data-registered="false">
        <div class="meter notification access alert alert-dismissable alert-warning hidden-print" data-message="blox login prompt">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            Viewed <span class="count"></span> of <span class="total"></span>
            
        </h4>
        
        
        <p><strong>Thank you for reading!
</strong> On your next view you will be asked to <span class="not-logged-in"><a class="alert-link" href="https://www.idahocountyfreepress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">log in</a> to your subscriber account or <a class="alert-link" href="https://www.idahocountyfreepress.com/users/signup/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">create an account</a> and subscribe</span><span class="logged-in"><a href="https://www.idahocountyfreepress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.idahocountyfreepress.com%252Fnews%252Fregional%252Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%252Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">purchase a subscription</a></span> to continue reading.</p>
        </div>
</template>
    
    <template class="template meter access" data-count="2">
        <div class="meter notification access alert alert-dismissable alert-warning hidden-print" data-message="blox last free">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            Viewed <span class="count"></span> of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for reading!
</strong> On your next view you will be asked to <span class="not-logged-in"><a class="alert-link" href="https://www.idahocountyfreepress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">log in</a> to your subscriber account or <a class="alert-link" href="https://www.idahocountyfreepress.com/users/signup/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">create an account</a> and subscribe</span><span class="logged-in"><a href="https://www.idahocountyfreepress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.idahocountyfreepress.com%252Fnews%252Fregional%252Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%252Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">purchase a subscription</a></span> to continue reading.</p>
    </div>
</template>
    
    <template class="template meter access" data-registered="true" data-after-wall="true">
        <div class="meter notification alert alert-dismissable alert-info" data-message="blox after login">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        
        <h4 class="clearfix meter-heading  media-heading row">
            Viewed <span class="count"></span> of <span class="total"></span>
            
        </h4>
        
        <p><strong>Thank you for signing in!</strong> We hope that you continue to enjoy our free content.</p>
    </div>
</template>
    
<div id="subscription-modal" class="subscription metering-modal modal fade" data-message="blox modal subscription">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="modal-title">Thank you for reading!
</h4>
            </div>

            <div class="modal-body">
                <div class="row">
                    <div class="col-xs-12">
                    <div class="not-logged-in">
                            <p>Please log in, or sign up for a new account and purchase a subscription to continue reading.
</p>
                        </div>
            
                        <div class="logged-in">
                            <div class="no-services" style="display:none">
                                <p>Please purchase a subscription to continue reading.
</p>
                            </div>
                
                            <div class="has-services" style="display:none">
                                <p>Your current subscription does not provide access to this content.
</p>
                            </div>
                        </div>

                        <div class="col-xs-12">
                            <div class="row not-logged-in padding-bottom">
                                <div class="col-xs-6">
                                    
    <a  class="btn btn-default btn-block" href="https://www.idahocountyfreepress.com/users/signup/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">Sign Up</a>
                                </div>
                                <div class="col-xs-6">
                                    
    <a class="btn btn-primary btn-block" href="https://www.idahocountyfreepress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">Log In</a>
                                </div>
                            </div>
                        </div>
                    <div class="col-xs-12">
                            <div class="row logged-in">
                                <div class="pull-right">
                                    <a class="btn btn-default" href="https://www.idahocountyfreepress.com/users/admin/service/purchase/?referer_url=https%253A%252F%252Fwww.idahocountyfreepress.com%252Fnews%252Fregional%252Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%252Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">Purchase a Subscription
</a>
                                </div>
                            </div>
                            </div>
                        
                        
                    </div>
                </div>
            </div>
            <div class="modal-footer">
                
            </div>
        </div>
    </div>
</div>

<script>
var promoOpenedFromModal = false;
$(function(){
    $('#service-promo-open').on('submit',function(){
    
        if($('#service-promo-open').find('input[name=promo]').val()!=""){
            $('#service-promo-modal').find('input[name=promo]').val($('#service-promo-open').find('input[name=promo]').val());
            $('#service-promo-modal').find('.promo-loading').show();
    
            if($('#subscription-modal').is(':visible')){
                $('#subscription-modal').modal('toggle');
                promoOpenedFromModal = true;
                setTimeout(function () {
                    $('#service-promo-modal').find('.modal').modal('toggle').submit();
                },500);
            }else{
                $('#service-promo-modal').find('.modal').modal('toggle').submit();
            }
       }
    
        return false;
    });
    
    if($("#service-promo-open").find("input[name=promo]").val()!=""){
        setTimeout(function () {
            $("#service-promo-open").find("button").click();
        },500);
    }
    
});
</script>

<form id="service-promo-modal" class="" method="post" action="https://www.idahocountyfreepress.com/content/tncms/live/" data-endpoint="https://www.idahocountyfreepress.com/tncms/subscription/services/?promoCode=">
    <input type="hidden" name="serviceid" value=""/>
    <input type="hidden" name="referer_url" value="/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"/>

    <div class="modal fade">
        <div class="modal-dialog">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close"><span aria-hidden="true">&times;</span></button>
                    <div class="form-group">
                        <label class="" for="promo">Have a promo code?</label>
                    </div>
                    <div class="form-group">
                        <div class="input-group">
                            <input type="text" class="form-control" name="promo" placeholder="Enter Code" value="">
                            <span class="input-group-btn"><button type="submit" class="btn btn-primary">Find Offers</button></span>
                        </div>
                    </div>
                </div>
                <div class="modal-body">
                    <template class="template promo-not-found-template">
                        <div class="promo-not-found-warning alert alert-warning">
    <p><strong>Sorry</strong>, no promotional deals were found matching that code.</p>
</div></template>
                    <template class="template promo-found-message-template">
                        <div class="promo-found-message alert alert-success clearfix">
    <p><strong>Promotional Rates</strong> were found for your code.
    
    </p>
</div></template>
                    <template class="template promo-error-template">
                        <div class="promo-error alert alert-warning">
    <p><strong>Sorry</strong>, an error occurred.</p>
</div></template>
                    
                    <div class="row">
                    <h2 class="promo-loading text-center font-larger" style="display:none;"><span class="fas tnt-spinner tnt-spin"></span></h2><div class="col-xs-12 service-promo-status-message"></div>
                    <div class="col-xs-12 output"></div>
                    </div>
                    
                    <template class="template-promo-service hide">
                        <div class="promotion-service subscription-service panel panel-default">
                            <h3 class="panel-heading"></h3>
                            <div class="panel-body">
                                <div class="service-note alert alert-info"></div>
                                <p class="description"></p>
                                <div class="rate-output"><p class="hide">do not remove</p></div>
                            </div>
                        </div>
                    </template>
                    <template class="template-promo-rate hide">
                        <div class="promotion subscription-service panel panel-default">
                            <div class="panel-body">
                                <h4 class="rate-name"></h4>
                                <div class="clearfix">
                                    <span class="pull-left">
                                        <div class="terms-automatic">
                                            <strong><span class="price"></span> <span class="duration"></span></strong>
                                            <small class="fine-print"></small>
                                        </div>
                                        <div class="terms-manual"></div>
                                    </span>
                                    <a data-subscription-service="" class="pull-right btn btn-primary rate-link">Get Started</a>
                                </div>
                            </div>
                        </div>
                    </template>

                </div>
                <div class="modal-footer">
                    <button type="button" class="btn btn-default pull-left" data-dismiss="modal">Back</button>
                </div>
            </div>
        </div>
    </div>
</form>
<script>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</script><script>

    $(function(){
        $('#service-promo-modal').on('submit',function(){
            var promoEl = $('#service-promo-modal');
            var promoVal = promoEl.find('input[name=promo]').val();
        
            __tnt.subscription.promos.fetch(promoEl, promoVal);
            
            $("#service-promo-modal").find("[data-dismiss=modal]").on('click',function(){
                if(promoOpenedFromModal){ 
                    $("#template-metering").find('.metering-modal').first().modal();
                    promoOpenedFromModal = true;
                }
            });

            return false;
        });
    });
</script>

<script>
    $(function(){
        var i = 0;
        $('#subscription-modal').find('.subscription-services').find('.subscription-service').each(function(){
            $(this).attr('id','service-tab-'+i);
        
            $(this).find('.panel-heading h3').html('<a href="" data-toggle="collapse" data-parent="services-modal-collapsable-tabs" aria-expanded="false" aria-controls="service-tab-'+i+'">'+$(this).find('.panel-heading h3').text()+'</a>')
            $(this).find('.panel-body').addClass('panel-collapse collapse').attr('role','tabpanel');
            
            if(i==0){
                $(this).find('.panel-collapse').collapse('show');
                $(this).find('.panel-footer').show();
            }else{
                $(this).find('.panel-footer').hide();
            }
        
            i++;
        });
    
        $('.subscription-services-filter').hide();
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').css({'padding':'0px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a').css({'display':'block','padding':'10px 15px'});
        $('#subscription-modal').find('.subscription-services .subscription-service .service-heading').find('a[data-toggle=collapse]').on('click',function(event){
            var id = $(this).attr('aria-controls');
            var open = $('#'+id).find('.collapse').hasClass('in');
            
            $('#subscription-modal').find('.subscription-services .subscription-service').each(function(){
                if(this.id == id){
                    $(this).find('.panel-collapse').collapse('show');
                    $(this).find('.panel-footer').show();
                }else{
                    $(this).find('.panel-collapse').collapse('hide');
                    $(this).find('.panel-footer').hide();
                }
            });
        });
        
        $('#asset-content').find('.subscription-required').find('.panel-footer').find('a[data-toggle=collapse]').on('click',function(event){
            $(this).parents('.panel-footer').find('.collapse.collapse-rates').collapse('toggle');
        });
        
        
        $('#asset-content').find('.meter-modal-open').on('click',function(){
            $('#asset-content').find('.alert.notification').css({'z-index':'900'});
            $("#template-metering").find('.metering-modal').first().modal();
        
        });
        
        $('#eedition-subscription').find('.meter-modal-open').on('click',function(){
            $("#template-metering").find('.metering-modal').first().modal();
        });
    });
    
</script>

    
</div>
<script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                
                bloxServiceIDs.push(3788);
                
                bloxServiceIDs.push(3140);
                
                bloxServiceIDs.push(2840);
                
                bloxServiceIDs.push(3069);
                
                bloxServiceIDs.push(2692);
                
                bloxServiceIDs.push(2828);
                
                bloxServiceIDs.push(2811);
                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.idahocountyfreepress.com/tncms/admin/editorial-asset/?edit=b3d8ee22-6286-11eb-82b1-43c8a113ada8"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-685952" class="tncms-block hidden-md hidden-lg"><div id="user-controls-685952" class="user-controls show-onload clearfix default"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.idahocountyfreepress.com/users/signup/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.idahocountyfreepress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.idahocountyfreepress.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-685952').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.idahocountyfreepress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.idahocountyfreepress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.idahocountyfreepress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-685952').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.idahocountyfreepress.com/users/logout/" id="user-logout-form-685952"><input type="hidden" name="referer_url" value="https://www.idahocountyfreepress.com/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/"  class="nav-link tnt-section-home">Home</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/contact.html"  class="nav-link tnt-section-contact-us">Contact Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/subscription_services/"  class="nav-link tnt-section-subscribe">Subscribe</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/eedition/"  class="nav-link tnt-section-e-edition">e-Edition</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/forms/"  class="nav-link tnt-section-submission-forms">Submission Forms</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/place_an_ad/"  class="nav-link tnt-section-place-an-ad">Place an Ad</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/weather/"  class="nav-link tnt-section-weather">Weather</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.idahopublicnotices.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-public-records">Public Records</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/local/"  class="nav-link tnt-section-local-news">Local News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/business/"  class="nav-link tnt-section-business">Business</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/education/"  class="nav-link tnt-section-education">Education</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/police-fire/"  class="nav-link tnt-section-police-and-fire">Police and Fire</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/grangeville/"  class="nav-link tnt-section-grangeville-news">Grangeville News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/cottonwood/"  class="nav-link tnt-section-cottonwood-news">Cottonwood News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/kamiah/"  class="nav-link tnt-section-kamiah-news">Kamiah News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/kooskia/"  class="nav-link tnt-section-kooskia-news">Kooskia News</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/white_bird/"  class="nav-link tnt-section-white-bird">White Bird</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/elk_city/"  class="nav-link tnt-section-elk-city">Elk City</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/records/"  class="nav-link tnt-section-records">Records</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/regional/"  class="nav-link tnt-section-regional-news-for-idaho-and-the-pacific-northwest">Regional News for Idaho and the Pacific Northwest</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/lowell_and_syringa/"  class="nav-link tnt-section-lowell-and-syringa">Lowell and Syringa</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/clearwater/"  class="nav-link tnt-section-clearwater">Clearwater</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/riggins/"  class="nav-link tnt-section-riggins">Riggins</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/state/"  class="nav-link tnt-section-state">State</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/news/covid-19/"  class="nav-link tnt-section-covid-19">Covid-19</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/outdoors/"  class="nav-link tnt-section-outdoors">Outdoors</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-5" data-target="#mobile-nav-right_menu-child-5">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/community/"  class="nav-link tnt-section-community">Community</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-5" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/calendar/"  class="nav-link tnt-section-calendar">Calendar</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/faith/"  class="nav-link tnt-section-faith">Faith</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/organizations/"  class="nav-link tnt-section-organizations">Organizations</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/people/"  class="nav-link tnt-section-people">People</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/community/school-news/"  class="nav-link tnt-section-school-news">School News</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/obituaries/"  class="nav-link tnt-section-obituaries">Obituaries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/guest-commentary/"  class="nav-link tnt-section-guest-commentary">Guest Commentary</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters-editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-8" data-target="#mobile-nav-right_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/milestones/"  class="nav-link tnt-section-milestones">Milestones</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/milestones/anniversaries/"  class="nav-link tnt-section-anniversaries">Anniversaries</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/milestones/births/"  class="nav-link tnt-section-births">Births</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/milestones/engagements/"  class="nav-link tnt-section-engagements">Engagements</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/milestones/weddings/"  class="nav-link tnt-section-weddings">Weddings</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/multimedia/"  class="nav-link tnt-section-multimedia">Multimedia</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-10" data-target="#mobile-nav-right_menu-child-10">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-10" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/place_an_ad/"  class="nav-link tnt-section-place-ad">Place ad</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-search-classifieds">Search classifieds</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-11" data-target="#mobile-nav-right_menu-child-11">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/special/"  class="nav-link tnt-section-special-sections">Special Sections</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-11" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/special/"  class="nav-link tnt-section-recent-special-sections">Recent special sections</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/get-acquainted/"  class="nav-link tnt-section-get-acquainted">Get Acquainted </a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/farm-and-ranch/"  class="nav-link tnt-section-farm-and-ranch">Farm and Ranch</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/experience/"  class="nav-link tnt-section-experience">Experience</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/home_and_garden/"  class="nav-link tnt-section-home-and-garden">Home and Garden</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="https://www.northcentralidahorealestate.com/"  target="_blank" rel="noopener" class="nav-link tnt-section-real-estate-guide">Real estate guide</a>
                                </li></ul></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "><div id="tncms-block-685948" class="tncms-block hidden-md hidden-lg"><section id="block-685948" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-685948" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-685948" aria-labelledby="site-search-button-685948" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-685948-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-685948-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-685948-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-685948').submit();
        return false;
    });

    $('#site-search-685948').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-685948 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-685948 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-685948-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-asset_skyline" class="tncms-region hidden-print"></div><div id="tncms-region-global-skyline" class="tncms-region "><div id="tncms-block-1015379" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1015379" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1015379');
                        
                });
            </script>
        </div>
    </div>
</div></div>
    

    
        <div id="site-top-nav-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-top-nav" class="container">
                <div class="row">
                    <div id="topbar-col-one" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-one" class="tncms-region "></div><div id="tncms-region-nav-topbar-col-one-nav" class="tncms-region-nav"><ul id="topbar-col-one-nav_menu" class="list-inline nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services/"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li></ul></div></div>
    <div id="topbar-col-two" class="col-md-6 col-sm-6"><div id="tncms-region-topbar-col-two" class="tncms-region "><div id="tncms-block-685947" class="tncms-block pull-right header-search"><ul id="site-search-685947-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-685947" aria-labelledby="site-search-button-685947" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right input-group-lg ">
        <input id="site-search-685947-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-685947-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-685947" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-685947-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-685947').submit();
        return false;
    });

    $('#site-search-685947').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-685947 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-685947 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-685947-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-685953" class="tncms-block pull-right header-weather"><div id="weather-685953" class="weather-current size-nav pull-right">
    <ul class="nav navbar-nav navbar-right">
        <li class="current-conditions dropdown">
            <a href="/weather/?weather_zip= 83530" class="dropdown-toggle" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250">
                <span class="icon pull-left">
                    
                    <span class="fas tnt-wi-night-clear"></span>
                </span>
                <span class="pull-left temp-desc nav">
                    <span class="temp">26&deg;</span>
                    
                </span>
                <span class="clearfix"></span>
            </a>
            
                <ul class="dropdown-menu" role="menu">
                    <li role="presentation">
                        <div class="weather-expanded">
                            <form action="/weather/" class="zip-update-form form-inline" method="get">
                                <input type="text" class="zip-update form-control" name="weather_zip" title="Weather ZIP Code" value=" 83530"> <input class="btn btn-primary" type="submit" value="GO">
                            </form>

                            <a href="javascript:;" class="pull-right zip-update-link" aria-label="weather_zip_toggle" onclick="jQuery('#weather-685953 .zip-update-form').toggle('fast'); return false;"><span class="fas tnt-cog"></span></a>

                            <h4 class="city-title"><i class="fas tnt-map-marker-alt"></i>
                                
                                    Grangeville, ID
                                
                                 <small>( 83530)</small>
                            </h4>
                            <h5>Today</h5>
                            <p>Partly cloudy skies this morning will give way to occasional snow showers during the afternoon. High 36F. Winds WSW at 5 to 10 mph. Chance of snow 70%. Snow accumulations less than one inch..</p>
                            <h5>Tonight</h5>
                            <p>Mostly cloudy with snow showers around before midnight. Low 28F. Winds WSW at 5 to 10 mph. Chance of snow 60%. Snow accumulations less than one inch.</p>
                            <p class="text-center"><small><i class="fas tnt-info-circle"></i> Updated: February 3, 2021 @ 5:26 am</small></p>
                        </div>
                    </li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem" class="forecast-link text-center"><a href="/weather/?weather_zip= 83530"><i class="fas tnt-caret-right"></i> Full Forecast</a></li>
                </ul>
            
        </li>
    </ul>
</div>
</div><div id="tncms-block-685949" class="tncms-block pull-right"><div class="follow-links-685949 pull-right">
    
    <section id="block-685949" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/idahocountyfreepress/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.idahocountyfreepress.com",
  "sameAs" : ["https://www.facebook.com/idahocountyfreepress/"]
}
</script>
<div class="clearfix"></div></div></div></div>
                </div>
            </header>
        </div>
    

    
        <div id="site-header-container" class="hidden-sm hidden-xs hidden-print">
            <header id="site-header" class="container" role="banner">
                
                <div class="row">
                    <div id="masthead-full-top" class="col-lg-12"><div id="tncms-region-masthead-full-top" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    
                    <div id="masthead-col-one" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-one" class="tncms-region "></div></div>
    <div id="masthead-col-two" class="col-md-6 col-sm-6">
        <div id="tncms-region-masthead-col-two" class="tncms-region "><div id="tncms-block-685899" class="tncms-block a"><section id="block-685899" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/custom/image/56208c22-e849-11e8-ad2b-b77f61d9fac0.png?resize=200%2C55 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/custom/image/56208c22-e849-11e8-ad2b-b77f61d9fac0.png?resize=300%2C83 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/custom/image/56208c22-e849-11e8-ad2b-b77f61d9fac0.png?resize=400%2C111 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/custom/image/56208c22-e849-11e8-ad2b-b77f61d9fac0.png?resize=540%2C150 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/custom/image/56208c22-e849-11e8-ad2b-b77f61d9fac0.png?resize=640%2C177 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/custom/image/56208c22-e849-11e8-ad2b-b77f61d9fac0.png 750w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="Idaho County Free Press"></a></div></section></div></div>
    </div>
    <div id="masthead-col-three" class="col-md-3 col-sm-3"><div id="tncms-region-masthead-col-three" class="tncms-region "></div></div>
                </div>
                <div class="row">
                    <div id="masthead-full-bottom" class="col-lg-12"><div id="tncms-region-masthead-full-bottom" class="tncms-region "></div></div>
                </div>
                
            </header>
        </div>
    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container navbar-static">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand hidden-md hidden-lg pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-685944" class="tncms-block"><section id="block-685944" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/custom/image/0e448818-bd1a-11e8-baf4-870e467517b1.png?resize=200%2C50 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/custom/image/0e448818-bd1a-11e8-baf4-870e467517b1.png?resize=300%2C74 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/custom/image/0e448818-bd1a-11e8-baf4-870e467517b1.png 400w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                alt="Idaho County Free Press"></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "><div id="tncms-block-685951" class="tncms-block pull-right header-user"><div id="user-controls-685951" class="user-controls show-onload clearfix pull-right"><div class="not-logged-in">
        <ul class="list-inline"><li><a href="https://www.idahocountyfreepress.com/users/signup/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html" class="btn btn-link btn-sm user-control-link" rel="nofollow">Sign Up</a></li><li>
                    <a href="https://www.idahocountyfreepress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html" class="btn btn-primary btn-sm login-btn user-control-link" rel="nofollow">
                        Log In
                    </a></li>
        </ul>
    </div>

    <div class="logged-in">
        
        
            <div class="hide show-offcanvas">
                <ul class="list-inline">
                    <li><a href="https://www.idahocountyfreepress.com/users/admin/" class="btn btn-primary btn-sm login-btn user-control-link">Dashboard</a></li>
                    <li> <a class="btn btn-link btn-sm user-control-link" onclick="document.getElementById('user-logout-form-685951').submit(); return false;" rel="nofollow"> Logout</a></li>
                </ul>
            </div>
        
        <ul class="hide-offcanvas list-inline">
            <li class="dropdown pull-right">
                
                <div class="dropdown-toggle btn btn-link btn-sm user-dropdown" data-toggle="dropdown" data-hover="dropdown" data-hover-delay="250"><div class="tn-user-avatar pull-left"><!-- user avatar --></div><span class="tn-user-screenname pull-left"></span><b class="caret user-control-link"></b>
                </div>
                <ul class="dropdown-menu dropdown-menu-right" role="menu">
                    <li role="presentation" class="dropdown-header">My Account</li>
                    <li role="menuitem"><a href="https://www.idahocountyfreepress.com/users/admin/" rel="nofollow"><i class="fas tnt-tachometer-alt tnt-fw"></i> Dashboard</a></li>
                    <li role="menuitem"><a class="tn-user-profile-url" href="" data-app="https://www.idahocountyfreepress.com/users/"><i class="fas tnt-user tnt-fw"></i> Profile</a></li>
                    <li role="menuitem"><a href="https://www.idahocountyfreepress.com/users/admin/list/" rel="nofollow"><i class="fas tnt-bookmark tnt-fw"></i> Saved items</a></li>
                    <li role="separator" class="divider"></li>
                    <li role="menuitem"><a class="logout-btn" onclick="document.getElementById('user-logout-form-685951').submit(); return false;" rel="nofollow"><i class="fas tnt-power-off tnt-fw"></i> Logout</a></li>
                </ul>
            </li>
        </ul>
    </div>
</div>

<form method="post" action="https://www.idahocountyfreepress.com/users/logout/" id="user-logout-form-685951"><input type="hidden" name="referer_url" value="https://www.idahocountyfreepress.com/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"><input type="submit" name="logout" value="Logout" class="hide">
</form></div><div id="tncms-block-742657" class="tncms-block"><ul id="block-742657" class="tnt-photo-sales-cart cart-nav nav navbar-nav navbar-right clearfix ">
        <li>
            <a href="#" class="open-cart user-control-link">
                <span class="badge-dot tnt-bg-accent cart-count" style="display:none;"></span>
                <i class="fas tnt-shopping-cart tnt-fw" aria-hidden="true"></i>
            </a>
        </li>
    </ul></div></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li class="dropdown" aria-expanded="false">
                <a class="nav-link  nav-home dropdown-toggle  tnt-section-home"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services/"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li><li>
                <a class="nav-link   tnt-section-e-edition"  href="/eedition/"  tabindex="0">
                    <span class="nav-label">e-Edition</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submission-forms"  href="/site/forms/"  tabindex="0">
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-place-an-ad"  href="/place_an_ad/"  tabindex="0">
                    <span class="nav-label">Place an Ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather/"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-public-records"  href="https://www.idahopublicnotices.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Public Records</span>
                </a></li><li>
                <a class="nav-link   tnt-section-local-news"  href="/news/local/"  tabindex="0">
                    <span class="nav-label">Local News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-business"  href="/news/business/"  tabindex="0">
                    <span class="nav-label">Business</span>
                </a></li><li>
                <a class="nav-link   tnt-section-education"  href="/news/education/"  tabindex="0">
                    <span class="nav-label">Education</span>
                </a></li><li>
                <a class="nav-link   tnt-section-police-and-fire"  href="/news/police-fire/"  tabindex="0">
                    <span class="nav-label">Police and Fire</span>
                </a></li><li>
                <a class="nav-link   tnt-section-grangeville-news"  href="/news/grangeville/"  tabindex="0">
                    <span class="nav-label">Grangeville News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cottonwood-news"  href="/news/cottonwood/"  tabindex="0">
                    <span class="nav-label">Cottonwood News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-kamiah-news"  href="/news/kamiah/"  tabindex="0">
                    <span class="nav-label">Kamiah News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-kooskia-news"  href="/news/kooskia/"  tabindex="0">
                    <span class="nav-label">Kooskia News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-white-bird"  href="/news/white_bird/"  tabindex="0">
                    <span class="nav-label">White Bird</span>
                </a></li><li>
                <a class="nav-link   tnt-section-elk-city"  href="/news/elk_city/"  tabindex="0">
                    <span class="nav-label">Elk City</span>
                </a></li><li>
                <a class="nav-link   tnt-section-records"  href="/news/records/"  tabindex="0">
                    <span class="nav-label">Records</span>
                </a></li><li>
                <a class="nav-link   tnt-section-regional-news-for-idaho-and-the-pacific-northwest"  href="/news/regional/"  tabindex="0">
                    <span class="nav-label">Regional News for Idaho and the Pacific Northwest</span>
                </a></li><li>
                <a class="nav-link   tnt-section-lowell-and-syringa"  href="/news/lowell_and_syringa/"  tabindex="0">
                    <span class="nav-label">Lowell and Syringa</span>
                </a></li><li>
                <a class="nav-link   tnt-section-clearwater"  href="/news/clearwater/"  tabindex="0">
                    <span class="nav-label">Clearwater</span>
                </a></li><li>
                <a class="nav-link   tnt-section-riggins"  href="/news/riggins/"  tabindex="0">
                    <span class="nav-label">Riggins</span>
                </a></li><li>
                <a class="nav-link   tnt-section-state"  href="/news/state/"  tabindex="0">
                    <span class="nav-label">State</span>
                </a></li><li>
                <a class="nav-link   tnt-section-covid-19"  href="/news/covid-19/"  tabindex="0">
                    <span class="nav-label">Covid-19</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-outdoors"  href="/outdoors/"  tabindex="0">
                    <span class="nav-label">Outdoors</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-community"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/community/"  tabindex="0">
                    <span class="nav-label">Community</span>
                </a><ul id="main-nav_menu-child-5" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-calendar"  href="/calendar/"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link   tnt-section-faith"  href="/community/faith/"  tabindex="0">
                    <span class="nav-label">Faith</span>
                </a></li><li>
                <a class="nav-link   tnt-section-organizations"  href="/community/organizations/"  tabindex="0">
                    <span class="nav-label">Organizations</span>
                </a></li><li>
                <a class="nav-link   tnt-section-people"  href="/community/people/"  tabindex="0">
                    <span class="nav-label">People</span>
                </a></li><li>
                <a class="nav-link   tnt-section-school-news"  href="/community/school-news/"  tabindex="0">
                    <span class="nav-label">School News</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries/"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-editorials"  href="/opinion/editorials/"  tabindex="0">
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link   tnt-section-guest-commentary"  href="/opinion/guest-commentary/"  tabindex="0">
                    <span class="nav-label">Guest Commentary</span>
                </a></li><li>
                <a class="nav-link   tnt-section-letters-to-the-editor"  href="/opinion/letters-editor/"  tabindex="0">
                    <span class="nav-label">Letters to the Editor</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-milestones"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/milestones/"  tabindex="0">
                    <span class="nav-label">Milestones</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-anniversaries"  href="/milestones/anniversaries/"  tabindex="0">
                    <span class="nav-label">Anniversaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-births"  href="/milestones/births/"  tabindex="0">
                    <span class="nav-label">Births</span>
                </a></li><li>
                <a class="nav-link   tnt-section-engagements"  href="/milestones/engagements/"  tabindex="0">
                    <span class="nav-label">Engagements</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weddings"  href="/milestones/weddings/"  tabindex="0">
                    <span class="nav-label">Weddings</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-multimedia"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Multimedia</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-classifieds"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a><ul id="main-nav_menu-child-10" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-place-ad"  href="/place_an_ad/"  tabindex="0">
                    <span class="nav-label">Place ad</span>
                </a></li><li>
                <a class="nav-link   tnt-section-search-classifieds"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Search classifieds</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-special-sections"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/special/"  tabindex="0">
                    <span class="nav-label">Special Sections</span>
                </a><ul id="main-nav_menu-child-11" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-recent-special-sections"  href="/special/"  tabindex="0">
                    <span class="nav-label">Recent special sections</span>
                </a></li><li>
                <a class="nav-link   tnt-section-get-acquainted"  href="/get-acquainted/"  tabindex="0">
                    <span class="nav-label">Get Acquainted </span>
                </a></li><li>
                <a class="nav-link   tnt-section-farm-and-ranch"  href="/farm-and-ranch/"  tabindex="0">
                    <span class="nav-label">Farm and Ranch</span>
                </a></li><li>
                <a class="nav-link   tnt-section-experience"  href="/experience/"  tabindex="0">
                    <span class="nav-label">Experience</span>
                </a></li><li>
                <a class="nav-link   tnt-section-home-and-garden"  href="/home_and_garden/"  tabindex="0">
                    <span class="nav-label">Home and Garden</span>
                </a></li><li>
                <a class="nav-link   tnt-section-real-estate-guide"  href="https://www.northcentralidahorealestate.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Real estate guide</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "><div id="tncms-block-1015370" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1015370" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1015370');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12"><div id="tncms-region-asset_container_top" class="tncms-region hidden-print"></div></div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-891948" class="tncms-block"><section id="block-891948" class="block emphasis-h3   " ><div id="promo-button-891948" class="promo-button"><a href="https://www.idahocountyfreepress.com/site/forms/subscription_services/#utm_source=blox&utm_campaign=button&utm_campaign_name=support_campaign_banner&utm_medium=utility_promo_button&utm_content=utility_promo_button"><button type="button" class="btn btn-block btn-lg"><div class="sticker">
                    <span class="far tnt-newspaper"></span>
                </div>Support local news! Subscribe today starting at $36 per year.</button></a></div></section></div></div></div>
        </div><div id="modal-image-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c" class="modal fullscreen in modal-image image-default modal-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=400%2C290"
                    srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=200%2C145 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=300%2C218 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=400%2C290 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=540%2C392 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=640%2C464 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=750%2C544 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=800%2C580 990w"
                    sizes="100vw"
                    
                    width="800"
                    height="580"
                    alt="Regional News standing"
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c" data-target=".caption-inner-modal-image-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c collapse in"><div class="caption-text"></div><div class="card-meta">
                        <ul class="list-inline">
                            
                                
                                
                                    <li class="credit"><span  class="tnt-byline">Internet image</span></li>
                                
                            
                            
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fregional-news-standing%2Fimage_66e1bc74-e1b8-11ea-8cab-af59af5e3d5c.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/regional-news-standing/image_66e1bc74-e1b8-11ea-8cab-af59af5e3d5c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66e1bc74-e1b8-11ea-8cab-af59af5e3d5c"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Regional%20News%20standing&url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fregional-news-standing%2Fimage_66e1bc74-e1b8-11ea-8cab-af59af5e3d5c.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/regional-news-standing/image_66e1bc74-e1b8-11ea-8cab-af59af5e3d5c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66e1bc74-e1b8-11ea-8cab-af59af5e3d5c"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahocountyfreepress.com/regional-news-standing/image_66e1bc74-e1b8-11ea-8cab-af59af5e3d5c.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/regional-news-standing/image_66e1bc74-e1b8-11ea-8cab-af59af5e3d5c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66e1bc74-e1b8-11ea-8cab-af59af5e3d5c"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahocountyfreepress.com/tncms/asset/editorial/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"66e1bc74-e1b8-11ea-8cab-af59af5e3d5c"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20County%20Free%20Press%5D%20Regional%20News%20standing&body=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fregional-news-standing%2Fimage_66e1bc74-e1b8-11ea-8cab-af59af5e3d5c.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"66e1bc74-e1b8-11ea-8cab-af59af5e3d5c"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/regional-news-standing/image_66e1bc74-e1b8-11ea-8cab-af59af5e3d5c.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"66e1bc74-e1b8-11ea-8cab-af59af5e3d5c"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="66e1bc74-e1b8-11ea-8cab-af59af5e3d5c" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="66e1bc74-e1b8-11ea-8cab-af59af5e3d5c" class="save-list-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="66e1bc74-e1b8-11ea-8cab-af59af5e3d5c" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c img { max-height: 580px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-b3d8ee22-6286-11eb-82b1-43c8a113ada8" class="asset article-default"  data-url="https://www.idahocountyfreepress.com/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=800%2C580">
            <meta itemprop="width" content="800">
            <meta itemprop="height" content="580">
        </div>
        <meta itemprop="name" content="idahocountyfreepress.com">
    </div>
    <link itemprop="mainEntityOfPage" href="https://www.idahocountyfreepress.com/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html" />
    <div class="asset-paging-container hidden-print" data-settings='{"assetType":"article","hasPageBreak":false,"isObit":false,"nextUrl":"https:\/\/www.idahocountyfreepress.com\/tncms\/search\/mlt\/?origin=b3d8ee22-6286-11eb-82b1-43c8a113ada8&app=editorial&preview=1&type=article%2Ccollection%2Cvideo%2Cyoutube","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8","isFluid":false,"isAdminVenue":false}'>
            <div id="asset-paging-b3d8ee22-6286-11eb-82b1-43c8a113ada8" class="asset-paging">
                <div id="paging-prev-b3d8ee22-6286-11eb-82b1-43c8a113ada8" class="paging-link prev offset"></div>
                <div id="paging-next-b3d8ee22-6286-11eb-82b1-43c8a113ada8" class="paging-link next offset"></div>
                <div class="clearfix"></div>
            </div>
        </div>
        <template id="asset-paging-template">
            <a class="animate arrow text-center">
                <span class=""></span>
                <span class="animate direction hidden-sm hidden-xs text-primary"></span>
            </a>
            <div class="animate item">
                <div class="dismiss" onclick="document.body.classList.add('trigger-disabled'); document.body.classList.remove('trigger-next'); return false;">
                    <span class="tnt-stack" aria-hidden="true">
                        <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                        <i class="fas tnt-times-circle tnt-stack-1x"></i>
                    </span>
                </div>
                <div class="inner">
                    <a class="overlay">
                        <span class="sr-only"></span>
                    </a>
                    <div class="head text-uppercase">
                        <small></small>
                    </div>
                    <div class="media">
                        <div class="media-body">
                            <h6 class="media-heading"></h6>
                            <p class="hidden-xs"></p>
                        </div>
                    </div>
                    <div class="clearfix"></div>
                </div>
            </div>
        </template><div class="asset-masthead ">
        <header class="asset-header">
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            Resident from Peck, Idaho to participate in 2022 Special Olympics
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        
        
            <li class="visible-print">
        <time datetime="2021-02-02T04:00:00-08:00" class="tnt-date asset-date text-muted">
            Feb 2, 2021
        </time></li>
            <li class="hidden-print">
        <time datetime="2021-02-02T04:00:00-08:00" class="tnt-date asset-date text-muted">Feb 2, 2021</time></li>
        
        
            <li class="hidden-print"><a href="/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html#comments" class="cm" title="0 comments"><span class="fas tnt-comments"></span> <span class="count">0</span></a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-02-02T04:00:00-08:00">
    <meta itemprop="datePublished" content="2021-02-02T04:00:00-08:00">
    <meta itemprop="dateModified" content="2021-02-02T04:00:00-08:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Resident%20from%20Peck%2C%20Idaho%20to%20participate%20in%202022%20Special%20Olympics&url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahocountyfreepress.com/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahocountyfreepress.com/tncms/asset/editorial/b3d8ee22-6286-11eb-82b1-43c8a113ada8" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20County%20Free%20Press%5D%20Resident%20from%20Peck%2C%20Idaho%20to%20participate%20in%202022%20Special%20Olympics&body=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="800">
            <meta itemprop="height" content="580">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg">
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=400%2C290"
                    srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=200%2C145 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=300%2C218 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=400%2C290 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=540%2C392 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=640%2C464 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=750%2C544 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/6/6e/66e1bc74-e1b8-11ea-8cab-af59af5e3d5c/5f3c7b8bbbb82.image.jpg?resize=800%2C580 990w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                    
                    width="800"
                    height="580"
                    alt="Regional News standing"
                    class="img-responsive full tnt-restrict-img-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c default" />
            </div><style>
                .tnt-restrict-img-66e1bc74-e1b8-11ea-8cab-af59af5e3d5c {
                    max-width: 800px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                        
                            <span class="credit">
                                <span  class="tnt-byline">Internet image</span>
                            </span>
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="b3d8ee22-6286-11eb-82b1-43c8a113ada8" data-smart-adunit="/132916964/idahocountyfreepress.com/news/regional">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Resident%20from%20Peck%2C%20Idaho%20to%20participate%20in%202022%20Special%20Olympics&url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahocountyfreepress.com/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahocountyfreepress.com/tncms/asset/editorial/b3d8ee22-6286-11eb-82b1-43c8a113ada8" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20County%20Free%20Press%5D%20Resident%20from%20Peck%2C%20Idaho%20to%20participate%20in%202022%20Special%20Olympics&body=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-b3d8ee22-6286-11eb-82b1-43c8a113ada8-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="b3d8ee22-6286-11eb-82b1-43c8a113ada8" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="b3d8ee22-6286-11eb-82b1-43c8a113ada8" class="save-list-b3d8ee22-6286-11eb-82b1-43c8a113ada8-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="b3d8ee22-6286-11eb-82b1-43c8a113ada8" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="false"/>
                                
                                
                                <div class="subscriber-preview"><p>Jeff Greene received a personal visit from some very important folks from the Special Olympics Idaho who had traveled long and far through the windstorm on Jan. 13, to officially announce that he, Jeff Greene, 38, of Peck, Idaho, would be traveling to Russia to participate in the winter games of the 2022 Special Olympics.</p></div><div class="subscriber-preview"><p>Jeff has participated in Special Olympics for almost 30 years. He began when he was eight with a team from Weippe.</p></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><div class="subscriber-only"><p>Jan. 27, Clearwater Tribune</p></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=Resident%20from%20Peck%2C%20Idaho%20to%20participate%20in%202022%20Special%20Olympics&url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=https://www.idahocountyfreepress.com/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share'>
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.idahocountyfreepress.com/tncms/asset/editorial/b3d8ee22-6286-11eb-82b1-43c8a113ada8" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='SMS Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5BIdaho%20County%20Free%20Press%5D%20Resident%20from%20Peck%2C%20Idaho%20to%20participate%20in%202022%20Special%20Olympics&body=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Email Share' rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"b3d8ee22-6286-11eb-82b1-43c8a113ada8"}' data-tncms-track-dmp='Social Media Share' rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-b3d8ee22-6286-11eb-82b1-43c8a113ada8-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="b3d8ee22-6286-11eb-82b1-43c8a113ada8" data-tncms-track-dmp='is_saved_items_user'>
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="b3d8ee22-6286-11eb-82b1-43c8a113ada8" class="save-list-b3d8ee22-6286-11eb-82b1-43c8a113ada8-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="b3d8ee22-6286-11eb-82b1-43c8a113ada8" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"><div id="tncms-block-893483" class="tncms-block"><section id="block-893483" class="block emphasis-h3   " ><div class="promo-design"><div class="sticker circle">
            <span class="far tnt-newspaper"></span>
        </div><div class="card-bg-color rectangle">
        <div class="card-panel panel">
             <div class="panel-body">
                <div class="promo-designer-wrapper">
                        <div class="lead-in dark text-shadow">
                            Your support is needed now more than ever
                        </div>
                    
                    
                        <div class="headline large dark ">
                            Help support your local news
                        </div>
                    
                    
                        <p class="text dark ">
                            Local news sources need your help. Stay in the know on Coronavirus, local updates, and more.
                        </p>
                    <div class="promo-design-button">
                            <a href="https://www.idahocountyfreepress.com/site/forms/subscription_services/#utm_source=blox&utm_campaign=subscribe_promo&utm_campaign_name=subscribe_promo_story_bottom&utm_medium=utility_promo_designer&utm_content=utility_promo_designer">
                                <button type="button" class="btn btn-primary btn-lg">Subscribe today</button>
                            </a>
                        </div>
                </div>   
            </div>
        </div>
    </div>
</div></section></div><div id="tncms-block-743551" class="tncms-block"><section id="block-743551" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-743551 ">
        <div class="block-title-inner">
            <h3>
                
                Recommended for you
                
            </h3>
        </div>
    </div></div><div id="card-grid-behavioral-743551" class="card-grid-behavioral card-grid card-img-"  data-lotame-track="true"><div class=" row equal equal-wrap"><div id="tncms-recommendations-743551" class="recommendations-container"></div>
            <div class="clearfix hidden-xs"></div>
            </div>
        </div></section></div></div><div class="asset-recommend native-programmatic hidden-print">
    <script id="yap_id1">
        var adUnitCode = adUnitCode || [];
        adUnitCode.push("814eb089-f8b4-4f96-b70d-67e791b10427");
        var apiKey = "DKGDKQMXH5RJCHRBRDXD";
        (function () {
            var script = document.createElement("script");
            script.async = true;
            script.src = "https://s.yimg.com/av/yap/ga/yap.js";
            document.body.appendChild(script);
        })();
        var yap_script = document.getElementById('yap_id1');
        var yap_parent_node = yap_script.parentNode;
        var container_yap_div = document.createElement('div');
        container_yap_div.className = 'yap-ad-814eb089-f8b4-4f96-b70d-67e791b10427';
        yap_parent_node.insertBefore(container_yap_div, yap_script);
    </script>
</div><div id="taboola-below-article-thumbnails" class="asset-recommend taboola hidden-print" data-page="article" data-mode="thumbnails-a" data-container="taboola-below-article-thumbnails" data-placement="Below Article Thumbnails"></div><div id="taboola-below-article-text-links" class="asset-recommend taboola hidden-print" data-page="article" data-mode="hybrid-text-links-a" data-container="taboola-below-article-text-links" data-placement="Below Article Text Links"></div>

                    <div class="asset-comments hidden-print">
<div id="commentPostModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Post a comment<span class="not-logged-in"> as </span></h4>
            </div>

            <form method="post" action="/tncms/comment/post/" id="commentPost">
                <input type="hidden" name="action" value="comments:post" />
                <input type="hidden" name="id" value="b3d8ee22-6286-11eb-82b1-43c8a113ada8" />
                <input type="hidden" name="app" value="editorial" />
                
                <div class="modal-body form-body">
                    
                    <div class="alert alert-info" style="display:none"></div>

                    

                    <a class="comment-emoticons-selector" data-toggle="collapse" data-target="#comment-emoticons-selector">Emoticons <span class="caret"></span></a>

                    <div id="comment-emoticons-selector" class="hidden-print collapse">
    <ul class="emoticon-selector list-unstyled list-inline">
        <li><a title="[smile]">[smile]</a></li>
        <li><a title="[beam]">[beam]</a></li>
        <li><a title="[wink]">[wink]</a></li>
        <li><a title="[sad]">[sad]</a></li>
        <li><a title="[cool]">[cool]</a></li>
        <li><a title="[innocent]">[innocent]</a></li>
        <li><a title="[rolleyes]">[rolleyes]</a></li>
        <li><a title="[whistling]">[whistling]</a></li>
        <li><a title="[lol]">[lol]</a></li>
        <li><a title="[huh]">[huh]</a></li>
        <li><a title="[tongue]">[tongue]</a></li>
        <li><a title="[love]">[love]</a></li>
        <li><a title="[sleeping]">[sleeping]</a></li>
        <li><a title="[yawn]">[yawn]</a></li>
        <li><a title="[unsure]">[unsure]</a></li>
        <li><a title="[angry]">[angry]</a></li>
        <li><a title="[blink]">[blink]</a></li>
        <li><a title="[crying]">[crying]</a></li>
        <li><a title="[ohmy]">[ohmy]</a></li>
        <li><a title="[scared]">[scared]</a></li>
        <li><a title="[sleep]">[sleep]</a></li>
        <li><a title="[sneaky]">[sneaky]</a></li>
        <li><a title="[tongue_smile]">[tongue_smile]</a></li>
        <li><a title="[thumbdown]">[thumbdown]</a></li>
        <li><a title="[thumbup]">[thumbup]</a></li>
        <li><a title="[censored]">[censored]</a></li>
        <li><a title="[happybirthday]">[happybirthday]</a></li>
        <li><a title="[ban]">[ban]</a></li>
        <li><a title="[spam]">[spam]</a></li>
        <li><a title="[offtopic]">[offtopic]</a></li>
        <li><a title="[batman]">[batman]</a></li>
        <li><a title="[ninja]">[ninja]</a></li>
        <li><a title="[pirate]">[pirate]</a></li>
        <li><a title="[alien]">[alien]</a></li>
        </ul>
</div>
                    
                    <div class="form-group">
                        <label class="sr-only" for="comment">Comment Text</label>
                        <textarea class="form-control" name="comment" id="comment" placeholder="Share your thoughts." required="required"></textarea>  
                    </div>
                    
                    
                
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button type="submit" class="btn btn-primary" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Posting">Post comment</button>
                    </div>
                </div>

                <template id="commentPostTemplate" class="template success">
                    <div class="media comment preview">
    <div class="alert alert-dismissable alert-success">
        <button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button>
        <p>Your comment has been submitted.</p>
    </div>

    <div class="comment-body media-body">
        <div class="comment-user">
            <div class="avatar img-responsive"><i class="fas tnt-user tnt-fw"></i></div>
            <img class="avatar img-responsive" src="" alt="" />
        </div>
        <div class="comment-heading  media-heading">
            <strong class="username"></strong>
        </div>
        <div class="comment-text">
            <p></p>
        </div>
    </div>
</div>
</template>

            </form>
        </div>
    </div>
</div>

<div id="commentReportModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">Report</h4>
            </div>

            <form id="commentReport" method="post" action="/news/regional/resident-from-peck-idaho-to-participate-in-2022-special-olympics/article_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">
                <input type="hidden" name="action" value="comments:abuse" />
                <input type="hidden" name="comment_id" value="" />
        
                <div class="modal-body">
                </div>
                
                <div class="modal-footer clearfix">
                    <div class="btn-group pull-left">
                        <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                    </div>
                    <div class="btn-group pull-right">
                        <button class="btn btn-danger" type="submit" data-loading-text="<span class='fas tnt-spinner tnt-spin'></span> Reporting">Report Abuse</button>
                    </div>
                </div>
        
                <template id="commentReportSuccessTemplate" class="template success">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>Reported</p></div>
                </template>

                <template id="commentReportErrorTemplate" class="template error">
                    <div class="reported alert alert-dismissable alert-danger"><button type="button" class="close" data-dismiss="alert" aria-hidden="true">&times;</button><p>There was a problem reporting this.</p></div>
                </template>

            </form>

        </div>
    </div>
</div>
<div id="commentSubscribeModal" class="modal fade">
    <div class="modal-dialog">
        <div class="modal-content">
            <div class="modal-header">
                <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button>
                <h4 class="heading modal-title">
                    <span class="subscribe">Watch this discussion.</span>
                    <span class="unsubscribe" style="display:none">Stop watching this discussion.</span>
                </h4>
            </div>
            <form id="commentSubscribe" method="post" action="/tncms/comment/subscribe/">
                <fieldset>
                    <legend class="sr-only">Watch this discussion</legend>
                    <input type="hidden" name="id" value="b3d8ee22-6286-11eb-82b1-43c8a113ada8" />
                    <input type="hidden" name="app" value="editorial" />
                    <div class="modal-body">
                        <div class="subscribe">
                            Get an email notification whenever someone contributes to the discussion
                        </div>
                        <div class="unsubscribe" style="display:none">
                            Notifications from this discussion will be disabled.
                        </div>
                        
                    </div>
                    <div class="modal-footer clearfix">
                        <div class="btn-group pull-left">
                            <button type="button" class="btn btn-default" data-dismiss="modal">Cancel</button>
                        </div>
                        <div class="btn-group pull-right">
                            <button type="submit" class="btn btn-primary">
                                <span class="subscribe">Start watching</span>
                                <span class="unsubscribe" style="display:none">Stop watching</span>
                            </button>
                        </div>
                    </div>
                </fieldset>
            </form>
        </div>
    </div>
</div><div id="comments-container" class="comments-container ">
        <section id="comments" class=" subscriber-hide"><div class="block-title comment-count-title">
                    <div class="block-title-inner">
                        <h3>
                            <span class="fas tnt-comments"></span> (0) comments 
                            
                        </h3>
                    </div>
                </div><div id="comment-area" class="padding-bottom desc usernames">
                
            </div>
            
            <div class="comments-control-panel panel panel-default hidden-print">
                <div class="panel-body">
                    <h3>Welcome to the discussion.</h3>
                    
                    <div class="not-logged-in">
                        <p class="comment-login">
                            
    <a class="btn btn-primary btn-block" href="https://www.idahocountyfreepress.com/users/login/?referer_url=https%3A%2F%2Fwww.idahocountyfreepress.com%2Fnews%2Fregional%2Fresident-from-peck-idaho-to-participate-in-2022-special-olympics%2Farticle_b3d8ee22-6286-11eb-82b1-43c8a113ada8.html">Log In</a>
                        </p>
                        
                    </div>
    
                    <div class="logged-in">
                        <p class="comment-rules"><strong>Keep it Clean.</strong> Please avoid obscene, vulgar, lewd,
racist or sexually-oriented language.<br>
<strong>PLEASE TURN OFF YOUR CAPS LOCK.</strong><br>
<strong>Don&#39;t Threaten.</strong> Threats of harming another
person will not be tolerated.<br>
<strong>Be Truthful.</strong> Don&#39;t knowingly lie about anyone
or anything.<br>
<strong>Be Nice.</strong> No racism, sexism or any sort of -ism
that is degrading to another person.<br>
<strong>Be Proactive.</strong> Use the &#39;Report&#39; link on
each comment to let us know of abusive posts.<br>
<strong>Share with Us.</strong> We&#39;d love to hear eyewitness
accounts, the history behind an article.
</p>
                        <div class="row">
                            <div class="col-sm-6">
                                <a class="comment-post btn btn-block btn-primary">Post a comment</a>
                            </div>
                            <div class="col-sm-6">
                                <a class="watch btn btn-block btn-default">
                                    <span class="subscribe">Watch this discussion.</span>
                                    <span class="unsubscribe">Stop watching this discussion.</span>
                                </a>
                            </div>
                        </div>
                    </div>
                </div>
            </div>
        </section>
    </div></div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-891927" class="tncms-block tnc-overlay"><section id="block-891927" class="block emphasis-h3   " ><div class="promo-design"><div class="card-bg-color rounded_rectangle">
        <div class="card-panel panel">
             <div class="panel-body">
                <div class="promo-designer-wrapper">
                    
                        <div class="headline medium light text-shadow">
                            Support Local Journalism
                        </div>
                    
                    
                        <p class="text light text-shadow">
                            Now, more than ever, the world needs trustworthy reporting—but good journalism isn’t free. Please support us by subscribing or making a contribution.
                        </p>
                    <div class="promo-design-button">
                            <a href="/contribute">
                                <button type="button" class="btn btn-danger btn-lg">Subscribe or contribute</button>
                            </a>
                        </div>
                </div>   
            </div>
        </div>
    </div>
</div></section></div><div id="tncms-block-1015371" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1015371" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1015371');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-685900" class="tncms-block"><section id="block-685900" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-685900 ">
        <div class="block-title-inner">
            <h4>
                
                Most Popular
                
            </h4>
        </div>
    </div></div><div class="most-popular">
    <ul class="nav nav-tabs nav-tabs-popular">
        
            <li class="active">
                <a href="#articles-685900" data-toggle="tab"><i class="far tnt-file-alt" title="Articles"></i><span class="tab-text"> Articles</span></a>
            </li>
        
        
            <li >
                <a href="#images-685900" data-toggle="tab"><i class="far tnt-image" title="images"></i><span class="tab-text"> Images</span></a>
            </li>
        
        
            <li >
                <a href="#videos-685900" data-toggle="tab"><i class="fas tnt-play-circle" title="Videos"></i><span class="tab-text"> Videos</span></a>
            </li>
        
        
        
        
            <li >
                <a href="#commented-685900" data-toggle="tab"><i class="far tnt-comments" title="Commented"></i><span class="tab-text"> Commented</span></a>
            </li>
        
    </ul>
    <div class="tab-content">
        
            <div id="articles-685900" class="tab-pane tab-pane-articles fade in active">
                <h4 class="tab-content-heading">Articles</h4><ul class="tab-content-list bullet-disc "><li><a href="/news/business/camas-lanes-changes-hands-bowling-alley-to-remain-a-family-business/article_19a9dcf2-6039-11eb-836c-efb23c65462b.html">Camas Lanes changes hands; bowling alley to remain a family business</a></li><li><a href="/news/fbi-analysis-determines-remains-found-in-2020-those-of-hofflander/article_6cc5a9be-6293-11eb-9af4-538e9f72ce44.html">FBI analysis determines remains found in 2020 those of Hofflander</a></li><li><a href="/news/patron-tries-to-speak-to-mvsd-board-about-upcoming-levy/article_179d9ea4-602e-11eb-b76f-ef113c43d5a0.html">Patron tries to speak to MVSD board about upcoming levy</a></li><li><a href="/news/idaho-senate-sends-back-bill-nullifying-the-covid-19-emergency-order/article_82ce9a36-6275-11eb-9623-8fdf70ddc5ae.html">Idaho Senate sends back bill nullifying the COVID-19 emergency order</a></li><li><a href="/news/10-questions-with-jim-schmidt/article_6a761692-6033-11eb-b5eb-fb3f3e28def3.html">10 Questions with Jim Schmidt</a></li><li><a href="/obituaries/leslie-ann-bowman-40/article_13f21470-6050-11eb-9666-5f56baeacae7.html">Leslie Ann Bowman, 40</a></li><li><a href="/news/local/grangeville-man-faces-federal-drug-charges/article_79e17d64-5ac1-11eb-b343-fb932b9d2f5f.html">Grangeville man faces federal drug charges</a></li><li><a href="/opinion/guest-opinion-can-t-afford-to-breach-first-and-answer-questions-later/article_e99b5494-603f-11eb-b5b4-537f55e6e230.html">Guest Opinion: Can’t afford to ‘breach first and answer questions later’</a></li><li><a href="/news/regional/investigation-ongoing-into-dent-bridge-road-crash/article_d35d5f86-60fa-11eb-82af-e7602b64158a.html">Investigation ongoing into Dent Bridge Road crash</a></li><li><a href="/news/regional/lapwai-methamphetamine-dealer-sentenced-to-10-years-in-federal-prison/article_a700abaa-60fa-11eb-842c-5702a9550a68.html">Lapwai methamphetamine dealer sentenced to 10 years in federal prison</a></li></ul></div>
        
        
            <div id="images-685900" class="tab-pane tab-pane-images fade in ">
                <h4 class="tab-content-heading">Images</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/st-maries-tops-ghs/image_97209a5a-637b-11eb-8002-ab2b5e4e7e44.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="St. Maries tops GHS"
                            class="img-responsive lazyload full default"
                            width="1174"
                            height="1174"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/72/97209a5a-637b-11eb-8002-ab2b5e4e7e44/60162ff342dee.image.jpg?crop=1174%2C1174%2C0%2C295&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/72/97209a5a-637b-11eb-8002-ab2b5e4e7e44/60162ff342dee.image.jpg?crop=1174%2C1174%2C0%2C295&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/72/97209a5a-637b-11eb-8002-ab2b5e4e7e44/60162ff342dee.image.jpg?crop=1174%2C1174%2C0%2C295&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/72/97209a5a-637b-11eb-8002-ab2b5e4e7e44/60162ff342dee.image.jpg?crop=1174%2C1174%2C0%2C295&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/72/97209a5a-637b-11eb-8002-ab2b5e4e7e44/60162ff342dee.image.jpg?crop=1174%2C1174%2C0%2C295&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/72/97209a5a-637b-11eb-8002-ab2b5e4e7e44/60162ff342dee.image.jpg?crop=1174%2C1174%2C0%2C295&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/72/97209a5a-637b-11eb-8002-ab2b5e4e7e44/60162ff342dee.image.jpg?crop=1174%2C1174%2C0%2C295&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/72/97209a5a-637b-11eb-8002-ab2b5e4e7e44/60162ff342dee.image.jpg?crop=1174%2C1174%2C0%2C295&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/72/97209a5a-637b-11eb-8002-ab2b5e4e7e44/60162ff342dee.image.jpg?crop=1174%2C1174%2C0%2C295&resize=1174%2C1174&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/denver-dreams/image_e6943dd6-5abf-11eb-8e6d-0b71d1962469.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Denver Dreams"
                            class="img-responsive lazyload full default"
                            width="1173"
                            height="1173"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/e/69/e6943dd6-5abf-11eb-8e6d-0b71d1962469/60078979ec48d.image.jpg?crop=1173%2C1173%2C296%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/e/69/e6943dd6-5abf-11eb-8e6d-0b71d1962469/60078979ec48d.image.jpg?crop=1173%2C1173%2C296%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/e/69/e6943dd6-5abf-11eb-8e6d-0b71d1962469/60078979ec48d.image.jpg?crop=1173%2C1173%2C296%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/e/69/e6943dd6-5abf-11eb-8e6d-0b71d1962469/60078979ec48d.image.jpg?crop=1173%2C1173%2C296%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/e/69/e6943dd6-5abf-11eb-8e6d-0b71d1962469/60078979ec48d.image.jpg?crop=1173%2C1173%2C296%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/e/69/e6943dd6-5abf-11eb-8e6d-0b71d1962469/60078979ec48d.image.jpg?crop=1173%2C1173%2C296%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/e/69/e6943dd6-5abf-11eb-8e6d-0b71d1962469/60078979ec48d.image.jpg?crop=1173%2C1173%2C296%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/e/69/e6943dd6-5abf-11eb-8e6d-0b71d1962469/60078979ec48d.image.jpg?crop=1173%2C1173%2C296%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/e/69/e6943dd6-5abf-11eb-8e6d-0b71d1962469/60078979ec48d.image.jpg?crop=1173%2C1173%2C296%2C0&resize=1173%2C1173&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/art-show-on-pleasant-valley-road/image_40b9ef0e-6038-11eb-a1fb-6fb5a57c1d68.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Art Show On Pleasant Valley Road"
                            class="img-responsive lazyload full default"
                            width="1176"
                            height="1176"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/0b/40b9ef0e-6038-11eb-a1fb-6fb5a57c1d68/6010b6f45a344.image.jpg?crop=1176%2C1176%2C293%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/0b/40b9ef0e-6038-11eb-a1fb-6fb5a57c1d68/6010b6f45a344.image.jpg?crop=1176%2C1176%2C293%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/0b/40b9ef0e-6038-11eb-a1fb-6fb5a57c1d68/6010b6f45a344.image.jpg?crop=1176%2C1176%2C293%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/0b/40b9ef0e-6038-11eb-a1fb-6fb5a57c1d68/6010b6f45a344.image.jpg?crop=1176%2C1176%2C293%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/0b/40b9ef0e-6038-11eb-a1fb-6fb5a57c1d68/6010b6f45a344.image.jpg?crop=1176%2C1176%2C293%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/0b/40b9ef0e-6038-11eb-a1fb-6fb5a57c1d68/6010b6f45a344.image.jpg?crop=1176%2C1176%2C293%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/0b/40b9ef0e-6038-11eb-a1fb-6fb5a57c1d68/6010b6f45a344.image.jpg?crop=1176%2C1176%2C293%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/0b/40b9ef0e-6038-11eb-a1fb-6fb5a57c1d68/6010b6f45a344.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/0b/40b9ef0e-6038-11eb-a1fb-6fb5a57c1d68/6010b6f45a344.image.jpg?crop=1176%2C1176%2C293%2C0&resize=1176%2C1176&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/community/break-in-the-storm/image_7e19c8aa-6048-11eb-875b-876656278ae3.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Break In The Storm"
                            class="img-responsive lazyload full default"
                            width="1247"
                            height="1247"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/7/e1/7e19c8aa-6048-11eb-875b-876656278ae3/6010d211c900a.image.jpg?crop=1247%2C1247%2C207%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/7/e1/7e19c8aa-6048-11eb-875b-876656278ae3/6010d211c900a.image.jpg?crop=1247%2C1247%2C207%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/7/e1/7e19c8aa-6048-11eb-875b-876656278ae3/6010d211c900a.image.jpg?crop=1247%2C1247%2C207%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/7/e1/7e19c8aa-6048-11eb-875b-876656278ae3/6010d211c900a.image.jpg?crop=1247%2C1247%2C207%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/7/e1/7e19c8aa-6048-11eb-875b-876656278ae3/6010d211c900a.image.jpg?crop=1247%2C1247%2C207%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/7/e1/7e19c8aa-6048-11eb-875b-876656278ae3/6010d211c900a.image.jpg?crop=1247%2C1247%2C207%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/7/e1/7e19c8aa-6048-11eb-875b-876656278ae3/6010d211c900a.image.jpg?crop=1247%2C1247%2C207%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/7/e1/7e19c8aa-6048-11eb-875b-876656278ae3/6010d211c900a.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/7/e1/7e19c8aa-6048-11eb-875b-876656278ae3/6010d211c900a.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/7/e1/7e19c8aa-6048-11eb-875b-876656278ae3/6010d211c900a.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1247%2C1247&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/community/a-chilly-hello/image_a994ef42-6038-11eb-9578-f307410f3616.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="A Chilly Hello"
                            class="img-responsive lazyload full default"
                            width="1173"
                            height="1173"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/a/99/a994ef42-6038-11eb-9578-f307410f3616/6010b7cd6b7af.image.jpg?crop=1173%2C1173%2C296%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/a/99/a994ef42-6038-11eb-9578-f307410f3616/6010b7cd6b7af.image.jpg?crop=1173%2C1173%2C296%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/a/99/a994ef42-6038-11eb-9578-f307410f3616/6010b7cd6b7af.image.jpg?crop=1173%2C1173%2C296%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/a/99/a994ef42-6038-11eb-9578-f307410f3616/6010b7cd6b7af.image.jpg?crop=1173%2C1173%2C296%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/a/99/a994ef42-6038-11eb-9578-f307410f3616/6010b7cd6b7af.image.jpg?crop=1173%2C1173%2C296%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/a/99/a994ef42-6038-11eb-9578-f307410f3616/6010b7cd6b7af.image.jpg?crop=1173%2C1173%2C296%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/a/99/a994ef42-6038-11eb-9578-f307410f3616/6010b7cd6b7af.image.jpg?crop=1173%2C1173%2C296%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/a/99/a994ef42-6038-11eb-9578-f307410f3616/6010b7cd6b7af.image.jpg?crop=1173%2C1173%2C296%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/a/99/a994ef42-6038-11eb-9578-f307410f3616/6010b7cd6b7af.image.jpg?crop=1173%2C1173%2C296%2C0&resize=1173%2C1173&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/community/grangeville-elementary-middle-school-choir/image_8b348554-5ac9-11eb-b5e8-cb9896f9e15c.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Grangeville Elementary Middle School Choir"
                            class="img-responsive lazyload full default"
                            width="928"
                            height="928"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/b3/8b348554-5ac9-11eb-b5e8-cb9896f9e15c/600799aee7c2a.image.jpg?crop=928%2C928%2C652%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/b3/8b348554-5ac9-11eb-b5e8-cb9896f9e15c/600799aee7c2a.image.jpg?crop=928%2C928%2C652%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/b3/8b348554-5ac9-11eb-b5e8-cb9896f9e15c/600799aee7c2a.image.jpg?crop=928%2C928%2C652%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/b3/8b348554-5ac9-11eb-b5e8-cb9896f9e15c/600799aee7c2a.image.jpg?crop=928%2C928%2C652%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/b3/8b348554-5ac9-11eb-b5e8-cb9896f9e15c/600799aee7c2a.image.jpg?crop=928%2C928%2C652%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/b3/8b348554-5ac9-11eb-b5e8-cb9896f9e15c/600799aee7c2a.image.jpg?crop=928%2C928%2C652%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/b3/8b348554-5ac9-11eb-b5e8-cb9896f9e15c/600799aee7c2a.image.jpg?crop=928%2C928%2C652%2C0&resize=928%2C928&order=crop%2Cresize 990w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/u-s-highway-12-vehicle-crash-photo/image_9a76d104-5608-11eb-a12f-afdc9da0fe67.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="U.S. Highway 12 vehicle crash photo"
                            class="img-responsive lazyload full default"
                            width="1247"
                            height="1247"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/a7/9a76d104-5608-11eb-a12f-afdc9da0fe67/5fff9fda44bb5.image.jpg?crop=1247%2C1247%2C207%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/a7/9a76d104-5608-11eb-a12f-afdc9da0fe67/5fff9fda44bb5.image.jpg?crop=1247%2C1247%2C207%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/a7/9a76d104-5608-11eb-a12f-afdc9da0fe67/5fff9fda44bb5.image.jpg?crop=1247%2C1247%2C207%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/a7/9a76d104-5608-11eb-a12f-afdc9da0fe67/5fff9fda44bb5.image.jpg?crop=1247%2C1247%2C207%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/a7/9a76d104-5608-11eb-a12f-afdc9da0fe67/5fff9fda44bb5.image.jpg?crop=1247%2C1247%2C207%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/a7/9a76d104-5608-11eb-a12f-afdc9da0fe67/5fff9fda44bb5.image.jpg?crop=1247%2C1247%2C207%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/a7/9a76d104-5608-11eb-a12f-afdc9da0fe67/5fff9fda44bb5.image.jpg?crop=1247%2C1247%2C207%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/a7/9a76d104-5608-11eb-a12f-afdc9da0fe67/5fff9fda44bb5.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/a7/9a76d104-5608-11eb-a12f-afdc9da0fe67/5fff9fda44bb5.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/a7/9a76d104-5608-11eb-a12f-afdc9da0fe67/5fff9fda44bb5.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1247%2C1247&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/community/lone-rider/image_490cc7a6-5ac2-11eb-b07b-87b8552a620d.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Lone Rider"
                            class="img-responsive lazyload full default"
                            width="1173"
                            height="1173"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/90/490cc7a6-5ac2-11eb-b07b-87b8552a620d/60078d7765822.image.jpg?crop=1173%2C1173%2C296%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/90/490cc7a6-5ac2-11eb-b07b-87b8552a620d/60078d7765822.image.jpg?crop=1173%2C1173%2C296%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/90/490cc7a6-5ac2-11eb-b07b-87b8552a620d/60078d7765822.image.jpg?crop=1173%2C1173%2C296%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/90/490cc7a6-5ac2-11eb-b07b-87b8552a620d/60078d7765822.image.jpg?crop=1173%2C1173%2C296%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/90/490cc7a6-5ac2-11eb-b07b-87b8552a620d/60078d7765822.image.jpg?crop=1173%2C1173%2C296%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/90/490cc7a6-5ac2-11eb-b07b-87b8552a620d/60078d7765822.image.jpg?crop=1173%2C1173%2C296%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/90/490cc7a6-5ac2-11eb-b07b-87b8552a620d/60078d7765822.image.jpg?crop=1173%2C1173%2C296%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/90/490cc7a6-5ac2-11eb-b07b-87b8552a620d/60078d7765822.image.jpg?crop=1173%2C1173%2C296%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/4/90/490cc7a6-5ac2-11eb-b07b-87b8552a620d/60078d7765822.image.jpg?crop=1173%2C1173%2C296%2C0&resize=1173%2C1173&order=crop%2Cresize 1200w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/community/emmanuel-baptist-church/image_85d011e8-4faa-11eb-8ef9-5ba947ea0925.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Emmanuel Baptist Church"
                            class="img-responsive lazyload full default"
                            width="1247"
                            height="1247"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/5d/85d011e8-4faa-11eb-8ef9-5ba947ea0925/5ff4f0ebe8ec4.image.jpg?crop=1247%2C1247%2C207%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/5d/85d011e8-4faa-11eb-8ef9-5ba947ea0925/5ff4f0ebe8ec4.image.jpg?crop=1247%2C1247%2C207%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/5d/85d011e8-4faa-11eb-8ef9-5ba947ea0925/5ff4f0ebe8ec4.image.jpg?crop=1247%2C1247%2C207%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/5d/85d011e8-4faa-11eb-8ef9-5ba947ea0925/5ff4f0ebe8ec4.image.jpg?crop=1247%2C1247%2C207%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/5d/85d011e8-4faa-11eb-8ef9-5ba947ea0925/5ff4f0ebe8ec4.image.jpg?crop=1247%2C1247%2C207%2C0&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/5d/85d011e8-4faa-11eb-8ef9-5ba947ea0925/5ff4f0ebe8ec4.image.jpg?crop=1247%2C1247%2C207%2C0&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/5d/85d011e8-4faa-11eb-8ef9-5ba947ea0925/5ff4f0ebe8ec4.image.jpg?crop=1247%2C1247%2C207%2C0&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/5d/85d011e8-4faa-11eb-8ef9-5ba947ea0925/5ff4f0ebe8ec4.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/5d/85d011e8-4faa-11eb-8ef9-5ba947ea0925/5ff4f0ebe8ec4.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/5d/85d011e8-4faa-11eb-8ef9-5ba947ea0925/5ff4f0ebe8ec4.image.jpg?crop=1247%2C1247%2C207%2C0&resize=1247%2C1247&order=crop%2Cresize 1333w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/kamiah/kub-pride/image_c19490ac-5aca-11eb-8b54-27780a6cd86d.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Kub Pride"
                            class="img-responsive lazyload full default"
                            width="1391"
                            height="1391"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=640%2C640&order=crop%2Cresize 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=750%2C750&order=crop%2Cresize 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=990%2C990&order=crop%2Cresize 990w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=1035%2C1035&order=crop%2Cresize 1035w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=1200%2C1200&order=crop%2Cresize 1200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=1333%2C1333&order=crop%2Cresize 1333w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/c/19/c19490ac-5aca-11eb-8b54-27780a6cd86d/60079bc7ea12a.image.jpg?crop=1391%2C1391%2C0%2C49&resize=1391%2C1391&order=crop%2Cresize 1476w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        <div id="videos-685900" class="tab-pane tab-pane-videos fade in ">
                <h4 class="tab-content-heading">Videos</h4><ul class="tab-content-list">
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/with-his-mother-hospitalized-kamaiu-johnson-unable-to-make-pga-tour-debut/video_8b3393f4-b619-5b14-ab21-2088133cf158.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="With his mother hospitalized, Kamaiu Johnson unable to make PGA Tour debut"
                            class="img-responsive lazyload full default"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/b3/8b3393f4-b619-5b14-ab21-2088133cf158/6012c719e64cc.image.jpg?crop=324%2C324%2C126%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/b3/8b3393f4-b619-5b14-ab21-2088133cf158/6012c719e64cc.image.jpg?crop=324%2C324%2C126%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/b3/8b3393f4-b619-5b14-ab21-2088133cf158/6012c719e64cc.image.jpg?crop=324%2C324%2C126%2C0&resize=324%2C324&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/parkland-survivor-responds-to-video-of-marjorie-taylor-greene-confronting-him/video_8216aa7a-20c2-5e30-b859-6a170dc2175d.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Parkland survivor responds to video of Marjorie Taylor Greene confronting him"
                            class="img-responsive lazyload full default"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/21/8216aa7a-20c2-5e30-b859-6a170dc2175d/6012c719c957e.image.jpg?crop=324%2C324%2C126%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/21/8216aa7a-20c2-5e30-b859-6a170dc2175d/6012c719c957e.image.jpg?crop=324%2C324%2C126%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/8/21/8216aa7a-20c2-5e30-b859-6a170dc2175d/6012c719c957e.image.jpg?crop=324%2C324%2C126%2C0&resize=324%2C324&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/former-qanon-supporter-to-cooper-i-apologize-for-thinking-you-ate-babies/video_565efc7a-b8a1-5607-9d8f-34305153427f.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Former QAnon supporter to Cooper: I apologize for thinking you ate babies"
                            class="img-responsive lazyload full default"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/5/65/565efc7a-b8a1-5607-9d8f-34305153427f/6014dadb3443f.image.jpg?crop=324%2C324%2C126%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/5/65/565efc7a-b8a1-5607-9d8f-34305153427f/6014dadb3443f.image.jpg?crop=324%2C324%2C126%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/5/65/565efc7a-b8a1-5607-9d8f-34305153427f/6014dadb3443f.image.jpg?crop=324%2C324%2C126%2C0&resize=324%2C324&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/robinhood-ceo-speaks-to-cuomo-after-gamestop-stock-chaos/video_f957de76-0245-5c71-91f2-821580b6707e.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Robinhood CEO speaks to Cuomo after GameStop stock chaos"
                            class="img-responsive lazyload full default"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/95/f957de76-0245-5c71-91f2-821580b6707e/601388d9d3dcd.image.jpg?crop=324%2C324%2C126%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/95/f957de76-0245-5c71-91f2-821580b6707e/601388d9d3dcd.image.jpg?crop=324%2C324%2C126%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/95/f957de76-0245-5c71-91f2-821580b6707e/601388d9d3dcd.image.jpg?crop=324%2C324%2C126%2C0&resize=324%2C324&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/legal-analyst-this-may-be-why-trumps-lawyers-left/video_9359d34b-720f-5bf6-b3dc-e8a5ceaed225.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Legal analyst: This may be why Trump's lawyers left"
                            class="img-responsive lazyload full default"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/35/9359d34b-720f-5bf6-b3dc-e8a5ceaed225/6016aa7479e67.image.jpg?crop=324%2C324%2C126%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/35/9359d34b-720f-5bf6-b3dc-e8a5ceaed225/6016aa7479e67.image.jpg?crop=324%2C324%2C126%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/35/9359d34b-720f-5bf6-b3dc-e8a5ceaed225/6016aa7479e67.image.jpg?crop=324%2C324%2C126%2C0&resize=324%2C324&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/what-a-reporter-learned-after-spending-3-weeks-in-qanon-chat-room/video_f63c0e9f-5317-52dc-ac1d-08ed13ab2a61.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="What a reporter learned after spending 3 weeks in QAnon chat room"
                            class="img-responsive lazyload full default"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/63/f63c0e9f-5317-52dc-ac1d-08ed13ab2a61/6011920196b3a.image.jpg?crop=324%2C324%2C126%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/63/f63c0e9f-5317-52dc-ac1d-08ed13ab2a61/6011920196b3a.image.jpg?crop=324%2C324%2C126%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/63/f63c0e9f-5317-52dc-ac1d-08ed13ab2a61/6011920196b3a.image.jpg?crop=324%2C324%2C126%2C0&resize=324%2C324&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/britney-spears-dances-to-holy-grail-featuring-justin-timberlake/video_95009bdd-70df-5577-bbf7-0ec49df1cf32.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Britney Spears dances to &quot;Holy Grail&quot; featuring Justin Timberlake"
                            class="img-responsive lazyload full default"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/50/95009bdd-70df-5577-bbf7-0ec49df1cf32/6012fc8be5dfe.image.jpg?crop=324%2C324%2C126%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/50/95009bdd-70df-5577-bbf7-0ec49df1cf32/6012fc8be5dfe.image.jpg?crop=324%2C324%2C126%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/9/50/95009bdd-70df-5577-bbf7-0ec49df1cf32/6012fc8be5dfe.image.jpg?crop=324%2C324%2C126%2C0&resize=324%2C324&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/doctor-reacts-to-frustrated-father-lashing-out-at-school-board-meeting/video_507d5ced-626d-5646-b080-36b2b955095a.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="Doctor reacts to frustrated father lashing out at school board meeting"
                            class="img-responsive lazyload full default"
                            width="324"
                            height="324"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/5/07/507d5ced-626d-5646-b080-36b2b955095a/6015c253c40a6.image.jpg?crop=324%2C324%2C126%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/5/07/507d5ced-626d-5646-b080-36b2b955095a/6015c253c40a6.image.jpg?crop=324%2C324%2C126%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/5/07/507d5ced-626d-5646-b080-36b2b955095a/6015c253c40a6.image.jpg?crop=324%2C324%2C126%2C0&resize=324%2C324&order=crop%2Cresize 400w" />
                </a>
                
            </div>
            
        </figure></li>
                        
                            <li><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/news/national/almost-ended-in-a-physical-fight-axios-reporter-describes-trump-meeting/video_f3c69847-ac29-562e-8f74-a7b34e877faa.html" class="tnt-asset-link">
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII="
                            alt="'Almost ended in a physical fight': Axios reporter describes Trump meeting"
                            class="img-responsive lazyload full default"
                            width="619"
                            height="619"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/3c/f3c69847-ac29-562e-8f74-a7b34e877faa/60198940497e1.image.jpg?crop=619%2C619%2C240%2C0&resize=200%2C200&order=crop%2Cresize 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/3c/f3c69847-ac29-562e-8f74-a7b34e877faa/60198940497e1.image.jpg?crop=619%2C619%2C240%2C0&resize=300%2C300&order=crop%2Cresize 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/3c/f3c69847-ac29-562e-8f74-a7b34e877faa/60198940497e1.image.jpg?crop=619%2C619%2C240%2C0&resize=400%2C400&order=crop%2Cresize 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/3c/f3c69847-ac29-562e-8f74-a7b34e877faa/60198940497e1.image.jpg?crop=619%2C619%2C240%2C0&resize=540%2C540&order=crop%2Cresize 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/editorial/f/3c/f3c69847-ac29-562e-8f74-a7b34e877faa/60198940497e1.image.jpg?crop=619%2C619%2C240%2C0&resize=619%2C619&order=crop%2Cresize 640w" />
                </a>
                
            </div>
            
        </figure></li>
                        </ul></div>
        
        
        
        
            <div id="commented-685900" class="tab-pane tab-pane-commented fade in ">
                <h4 class="tab-content-heading">Commented</h4><ul class="tab-content-list bullet-disc "><li><a href="/news/patron-tries-to-speak-to-mvsd-board-about-upcoming-levy/article_179d9ea4-602e-11eb-b76f-ef113c43d5a0.html">Patron tries to speak to MVSD board about upcoming levy</a> (1)</li><li><a href="/community/guest-column-take-time-to-reflect-as-we-kiss-2020-goodbye/article_1d399d68-5552-11eb-bbb3-6b9f2e395899.html">Guest Column: Take time to reflect as we kiss 2020 goodbye</a> (1)</li><li><a href="/opinion/letter-doesn-t-bother-brainwashed-republicans-trump-abused-power/article_f338b98c-5ac3-11eb-b343-332555008918.html">LETTER: Doesn’t bother brainwashed Republicans Trump abused power</a> (1)</li></ul></div>
        
    </div>
</div></section></div><div id="tncms-block-685848" class="tncms-block"></div><div id="tncms-block-685879" class="tncms-block"><section id="block-685879" class="block emphasis-h2   " ><div class="clearfix">
    
    <div class="block-title title-685879 ">
        <div class="block-title-inner">
            <h2>
                
                Featured Advertisers
                
            </h2>
        </div>
    </div></div>
    
        <div class="card-panel panel">
            <div class="panel-body">
    
    <div class="masonry grid-cols-2" data-grid-cols="2">
        
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.idahocountyfreepress.com/classifieds/other/ads/11259-syringa-hospital/pdfdisplayad_1ab63e04-5b18-5941-9fbf-bdec0e3fff70.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-685879" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'  'tnt-lightboxbulletin-openpdfdisplayad1 data-title="11259 Syringa Hospital"><span class="title">11259 Syringa Hospital</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="11259 Syringa Hospital"
                            class="img-responsive lazyload full default"
                            width="988"
                            height="1000"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/1/ab/1ab63e04-5b18-5941-9fbf-bdec0e3fff70/6009d64b2dadd.preview.jpg?resize=200%2C202 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/1/ab/1ab63e04-5b18-5941-9fbf-bdec0e3fff70/6009d64b2dadd.preview.jpg?resize=300%2C304 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/1/ab/1ab63e04-5b18-5941-9fbf-bdec0e3fff70/6009d64b2dadd.preview.jpg?resize=400%2C405 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/1/ab/1ab63e04-5b18-5941-9fbf-bdec0e3fff70/6009d64b2dadd.preview.jpg?resize=540%2C547 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/1/ab/1ab63e04-5b18-5941-9fbf-bdec0e3fff70/6009d64b2dadd.preview.jpg?resize=640%2C648 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/1/ab/1ab63e04-5b18-5941-9fbf-bdec0e3fff70/6009d64b2dadd.preview.jpg?resize=750%2C759 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/1/ab/1ab63e04-5b18-5941-9fbf-bdec0e3fff70/6009d64b2dadd.preview.jpg?resize=988%2C1000 990w" />
                
                
            </div>
            
        </figure></div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.idahocountyfreepress.com/classifieds/other/ads/11233-quality-heating-air/pdfdisplayad_d5c21593-2985-5736-8c77-663ce57d22d0.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-685879" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'  'tnt-lightboxbulletin-openpdfdisplayad1 data-title="11233 Quality Heating Air"><span class="title">11233 Quality Heating Air</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="11233 Quality Heating Air"
                            class="img-responsive lazyload full default"
                            width="988"
                            height="1000"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/5c/d5c21593-2985-5736-8c77-663ce57d22d0/6010b41be8752.preview.jpg?resize=200%2C202 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/5c/d5c21593-2985-5736-8c77-663ce57d22d0/6010b41be8752.preview.jpg?resize=300%2C304 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/5c/d5c21593-2985-5736-8c77-663ce57d22d0/6010b41be8752.preview.jpg?resize=400%2C405 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/5c/d5c21593-2985-5736-8c77-663ce57d22d0/6010b41be8752.preview.jpg?resize=540%2C547 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/5c/d5c21593-2985-5736-8c77-663ce57d22d0/6010b41be8752.preview.jpg?resize=640%2C648 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/5c/d5c21593-2985-5736-8c77-663ce57d22d0/6010b41be8752.preview.jpg?resize=750%2C759 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/5c/d5c21593-2985-5736-8c77-663ce57d22d0/6010b41be8752.preview.jpg?resize=988%2C1000 990w" />
                
                
            </div>
            
        </figure></div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.idahocountyfreepress.com/classifieds/other/ads/11150-st-marys-hospital/pdfdisplayad_eae52ac2-b4ff-5d34-bd67-f3dbe734d784.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-685879" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'  'tnt-lightboxbulletin-openpdfdisplayad1 data-title="11150 St Marys Hospital"><span class="title">11150 St Marys Hospital</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="11150 St Marys Hospital"
                            class="img-responsive lazyload full default"
                            width="988"
                            height="1000"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/e/ae/eae52ac2-b4ff-5d34-bd67-f3dbe734d784/6010b41b3a961.preview.jpg?resize=200%2C202 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/e/ae/eae52ac2-b4ff-5d34-bd67-f3dbe734d784/6010b41b3a961.preview.jpg?resize=300%2C304 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/e/ae/eae52ac2-b4ff-5d34-bd67-f3dbe734d784/6010b41b3a961.preview.jpg?resize=400%2C405 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/e/ae/eae52ac2-b4ff-5d34-bd67-f3dbe734d784/6010b41b3a961.preview.jpg?resize=540%2C547 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/e/ae/eae52ac2-b4ff-5d34-bd67-f3dbe734d784/6010b41b3a961.preview.jpg?resize=640%2C648 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/e/ae/eae52ac2-b4ff-5d34-bd67-f3dbe734d784/6010b41b3a961.preview.jpg?resize=750%2C759 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/e/ae/eae52ac2-b4ff-5d34-bd67-f3dbe734d784/6010b41b3a961.preview.jpg?resize=988%2C1000 990w" />
                
                
            </div>
            
        </figure></div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.idahocountyfreepress.com/classifieds/other/ads/11304-all-around-realty/pdfdisplayad_4c4dfb33-94c7-5149-81fc-6ce7af294307.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-685879" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'  'tnt-lightboxbulletin-openpdfdisplayad1 data-title="11304 All Around Realty"><span class="title">11304 All Around Realty</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="11304 All Around Realty"
                            class="img-responsive lazyload full default"
                            width="650"
                            height="800"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/4/c4/4c4dfb33-94c7-5149-81fc-6ce7af294307/6010b41fdbba1.preview.jpg?resize=200%2C246 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/4/c4/4c4dfb33-94c7-5149-81fc-6ce7af294307/6010b41fdbba1.preview.jpg?resize=300%2C369 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/4/c4/4c4dfb33-94c7-5149-81fc-6ce7af294307/6010b41fdbba1.preview.jpg?resize=400%2C492 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/4/c4/4c4dfb33-94c7-5149-81fc-6ce7af294307/6010b41fdbba1.preview.jpg?resize=540%2C665 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/4/c4/4c4dfb33-94c7-5149-81fc-6ce7af294307/6010b41fdbba1.preview.jpg?resize=640%2C788 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/4/c4/4c4dfb33-94c7-5149-81fc-6ce7af294307/6010b41fdbba1.preview.jpg?resize=650%2C800 750w" />
                
                
            </div>
            
        </figure></div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.idahocountyfreepress.com/classifieds/other/ads/11335-pine-tree-community-credit/pdfdisplayad_898b862e-17b8-57aa-9aba-57c7255b9f03.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-685879" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'  'tnt-lightboxbulletin-openpdfdisplayad1 data-title="11335 Pine Tree Community Credit"><span class="title">11335 Pine Tree Community Credit</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="11335 Pine Tree Community Credit"
                            class="img-responsive lazyload full default"
                            width="650"
                            height="800"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/8/98/898b862e-17b8-57aa-9aba-57c7255b9f03/6010b4224bda8.preview.jpg?resize=200%2C246 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/8/98/898b862e-17b8-57aa-9aba-57c7255b9f03/6010b4224bda8.preview.jpg?resize=300%2C369 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/8/98/898b862e-17b8-57aa-9aba-57c7255b9f03/6010b4224bda8.preview.jpg?resize=400%2C492 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/8/98/898b862e-17b8-57aa-9aba-57c7255b9f03/6010b4224bda8.preview.jpg?resize=540%2C665 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/8/98/898b862e-17b8-57aa-9aba-57c7255b9f03/6010b4224bda8.preview.jpg?resize=640%2C788 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/8/98/898b862e-17b8-57aa-9aba-57c7255b9f03/6010b4224bda8.preview.jpg?resize=650%2C800 750w" />
                
                
            </div>
            
        </figure></div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.idahocountyfreepress.com/classifieds/other/ads/10835-clear-connect/pdfdisplayad_dd6f7a7f-e54c-5c18-a018-637154bdb9f0.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-685879" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'  'tnt-lightboxbulletin-openpdfdisplayad1 data-title="10835 Clear Connect"><span class="title">10835 Clear Connect</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-horizontal ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="10835 Clear Connect"
                            class="img-responsive lazyload full default"
                            width="1325"
                            height="800"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/d6/dd6f7a7f-e54c-5c18-a018-637154bdb9f0/6010b41a47403.preview.jpg?resize=200%2C121 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/d6/dd6f7a7f-e54c-5c18-a018-637154bdb9f0/6010b41a47403.preview.jpg?resize=300%2C181 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/d6/dd6f7a7f-e54c-5c18-a018-637154bdb9f0/6010b41a47403.preview.jpg?resize=400%2C242 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/d6/dd6f7a7f-e54c-5c18-a018-637154bdb9f0/6010b41a47403.preview.jpg?resize=540%2C326 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/d6/dd6f7a7f-e54c-5c18-a018-637154bdb9f0/6010b41a47403.preview.jpg?resize=640%2C386 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/d6/dd6f7a7f-e54c-5c18-a018-637154bdb9f0/6010b41a47403.preview.jpg?resize=750%2C453 750w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/d6/dd6f7a7f-e54c-5c18-a018-637154bdb9f0/6010b41a47403.preview.jpg?resize=990%2C598 990w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/d6/dd6f7a7f-e54c-5c18-a018-637154bdb9f0/6010b41a47403.preview.jpg?resize=1035%2C625 1035w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/d6/dd6f7a7f-e54c-5c18-a018-637154bdb9f0/6010b41a47403.preview.jpg?resize=1200%2C725 1200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/d6/dd6f7a7f-e54c-5c18-a018-637154bdb9f0/6010b41a47403.preview.jpg?resize=1325%2C800 1333w" />
                
                
            </div>
            
        </figure></div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.idahocountyfreepress.com/classifieds/other/ads/11402-tackett-saw-service/pdfdisplayad_df5f7637-7987-584f-a5c4-e1ea9c36398a.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-685879" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'  'tnt-lightboxbulletin-openpdfdisplayad1 data-title="11402 Tackett Saw Service"><span class="title">11402 Tackett Saw Service</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-horizontal ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="11402 Tackett Saw Service"
                            class="img-responsive lazyload full default"
                            width="650"
                            height="600"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/f5/df5f7637-7987-584f-a5c4-e1ea9c36398a/6010b4248b8fc.preview.jpg?resize=200%2C185 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/f5/df5f7637-7987-584f-a5c4-e1ea9c36398a/6010b4248b8fc.preview.jpg?resize=300%2C277 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/f5/df5f7637-7987-584f-a5c4-e1ea9c36398a/6010b4248b8fc.preview.jpg?resize=400%2C369 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/f5/df5f7637-7987-584f-a5c4-e1ea9c36398a/6010b4248b8fc.preview.jpg?resize=540%2C498 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/f5/df5f7637-7987-584f-a5c4-e1ea9c36398a/6010b4248b8fc.preview.jpg?resize=640%2C591 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/d/f5/df5f7637-7987-584f-a5c4-e1ea9c36398a/6010b4248b8fc.preview.jpg?resize=650%2C600 750w" />
                
                
            </div>
            
        </figure></div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.idahocountyfreepress.com/classifieds/other/ads/11302-highland-realty/pdfdisplayad_2fbcc66d-2da0-5b0b-b801-900556467843.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-685879" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'  'tnt-lightboxbulletin-openpdfdisplayad1 data-title="11302 Highland Realty"><span class="title">11302 Highland Realty</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="11302 Highland Realty"
                            class="img-responsive lazyload full default"
                            width="650"
                            height="800"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/2/fb/2fbcc66d-2da0-5b0b-b801-900556467843/6010b41f2a67a.preview.jpg?resize=200%2C246 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/2/fb/2fbcc66d-2da0-5b0b-b801-900556467843/6010b41f2a67a.preview.jpg?resize=300%2C369 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/2/fb/2fbcc66d-2da0-5b0b-b801-900556467843/6010b41f2a67a.preview.jpg?resize=400%2C492 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/2/fb/2fbcc66d-2da0-5b0b-b801-900556467843/6010b41f2a67a.preview.jpg?resize=540%2C665 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/2/fb/2fbcc66d-2da0-5b0b-b801-900556467843/6010b41f2a67a.preview.jpg?resize=640%2C788 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/2/fb/2fbcc66d-2da0-5b0b-b801-900556467843/6010b41f2a67a.preview.jpg?resize=650%2C800 750w" />
                
                
            </div>
            
        </figure></div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.idahocountyfreepress.com/classifieds/other/ads/11400-idaho-county-vet-center/pdfdisplayad_ad64af01-a7d4-52a6-84fd-bc4d51a80f0d.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-685879" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'  'tnt-lightboxbulletin-openpdfdisplayad1 data-title="11400 Idaho County Vet Center"><span class="title">11400 Idaho County Vet Center</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-horizontal ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="11400 Idaho County Vet Center"
                            class="img-responsive lazyload full default"
                            width="650"
                            height="500"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/a/d6/ad64af01-a7d4-52a6-84fd-bc4d51a80f0d/6010b423aa7bb.preview.jpg?resize=200%2C154 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/a/d6/ad64af01-a7d4-52a6-84fd-bc4d51a80f0d/6010b423aa7bb.preview.jpg?resize=300%2C231 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/a/d6/ad64af01-a7d4-52a6-84fd-bc4d51a80f0d/6010b423aa7bb.preview.jpg?resize=400%2C308 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/a/d6/ad64af01-a7d4-52a6-84fd-bc4d51a80f0d/6010b423aa7bb.preview.jpg?resize=540%2C415 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/a/d6/ad64af01-a7d4-52a6-84fd-bc4d51a80f0d/6010b423aa7bb.preview.jpg?resize=640%2C492 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/a/d6/ad64af01-a7d4-52a6-84fd-bc4d51a80f0d/6010b423aa7bb.preview.jpg?resize=650%2C500 750w" />
                
                
            </div>
            
        </figure></div>
          </div>
        
        <div class="masonry-brick">
            <div class="masonry-content">
                <a href="https://www.idahocountyfreepress.com/classifieds/other/ads/11305-solberg-agency/pdfdisplayad_b135ab99-40b2-56b7-8327-69ee30570c12.html" class="overlay" data-toggle="modal" data-target="#bulletins-modal-685879" data-remote="false" data-track='{"category":"tnt-lightbox","action":"bulletin-open","label":"pdfdisplayad","value":"1"}'  'tnt-lightboxbulletin-openpdfdisplayad1 data-title="11305 Solberg Agency"><span class="title">11305 Solberg Agency</span><span class="fas tnt-search-plus"></span>
                </a><figure class="photo layout-vertical ">
            <div class="image" 
                >
                
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="11305 Solberg Agency"
                            class="img-responsive lazyload full default"
                            width="650"
                            height="1600"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/b/13/b135ab99-40b2-56b7-8327-69ee30570c12/6010b420980e2.preview.jpg?resize=200%2C492 200w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/b/13/b135ab99-40b2-56b7-8327-69ee30570c12/6010b420980e2.preview.jpg?resize=300%2C738 300w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/b/13/b135ab99-40b2-56b7-8327-69ee30570c12/6010b420980e2.preview.jpg?resize=400%2C985 400w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/b/13/b135ab99-40b2-56b7-8327-69ee30570c12/6010b420980e2.preview.jpg?resize=540%2C1329 540w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/b/13/b135ab99-40b2-56b7-8327-69ee30570c12/6010b420980e2.preview.jpg?resize=640%2C1575 640w, https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/content/tncms/assets/v3/classifieds/b/13/b135ab99-40b2-56b7-8327-69ee30570c12/6010b420980e2.preview.jpg?resize=650%2C1600 750w" />
                
                
            </div>
            
        </figure></div>
          </div></div>
    <div class="modal bulletins-modal" id="bulletins-modal-685879" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true">
        <div class="modal-dialog modal-lg">
            <div class="modal-content">
                <div class="modal-header">
                    <button type="button" class="close" data-dismiss="modal" aria-label="Close"><i aria-hidden="true" class="fas tnt-times"></i></button>
                    <h4 class="modal-title" id="myModalLabel">Bulletin</h4>
                </div>
                <div class="modal-body">
                    <iframe title="bulletins-iframe"></iframe>
                </div>
            </div>
        </div>
    </div>
    
            </div>
        </div>
     
    <div class="clearfix"></div>
    </section></div><div id="tncms-block-1015373" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1015373" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1015373');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-685861" class="tncms-block"><section id="block-685861" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-685861 ">
        <div class="block-title-inner">
            <h4>
                
                Latest News
                
            </h4>
        </div>
    </div></div>
    <div class=""><ul class="card headline-list bullet-square border border-dashed"><li class="">
            <span class="tnt-headline ">
        
             <a href="/community/school-news/mvsd-board-decides-to-run-levy-in-may-smith-s-motion-to-go-for-2/article_e20e8128-65a9-11eb-8c0e-ff6eebc89d76.html" class="tnt-asset-link">
        

        
            MVSD board decides to run levy in May; Smith’s motion to go for $2.2 million dies</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/syringa-sees-revenue-losses-in-2020/article_8d95bd1a-65ad-11eb-877b-435d8ebc6c5d.html" class="tnt-asset-link">
        

        
            Syringa sees revenue losses in 2020</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/on-idaho-education-funding-tall-order-to-change-things/article_c9c82dce-65ab-11eb-8ff9-87fc5964a848.html" class="tnt-asset-link">
        

        
            On Idaho education funding; ‘Tall order to change things’</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/camel-gets-city-ok-to-return-for-border-days/article_2bf28108-65ab-11eb-aa14-e78e6d645b73.html" class="tnt-asset-link">
        

        
            Camel gets city OK to return for Border Days</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/outdoors/chinook-fishing-comments-open-feb-11/article_c95225b2-65b4-11eb-a3fb-cb37f1db266a.html" class="tnt-asset-link">
        

        
            Chinook fishing comments open Feb. 11</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/sports/prairie-lets-as-regular-season-winds-down/article_5c53586e-65b4-11eb-a34d-5b5f781ce8cd.html" class="tnt-asset-link">
        

        
            Prairie lets as regular season winds down</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/outdoors/f-g-to-publish-big-game-proposals-feb-8/article_4a8475e0-65b5-11eb-975c-2b0e47daa8b2.html" class="tnt-asset-link">
        

        
            F&G to publish big game proposals Feb. 8</a></span>
        </li><li class="">
            <span class="tnt-headline ">
        
             <a href="/news/records/idaho-county-district-court/article_38a10aaa-65ba-11eb-8285-bbcb03e89063.html" class="tnt-asset-link">
        

        
            Idaho County District Court</a></span>
        </li></ul></div></section></div><div id="tncms-block-690721" class="tncms-block"><div class="block">
<div class="clearfix">
    <div class="block-title">
        <div class="block-title-inner">
            <h4>
                
                News and information from our community partners
                
            </h4>
        </div>
    </div>
</div>
<iframe style="display:block; margin:0 auto 40px;" src="https://idahocountyfreepress.friends2follow.com/f2f/widget/html/socialstack/95/0/20/140/1/2/1/5" width="300px" height="600px" frameborder="0" scrolling="no"></iframe>
</div></div><div id="tncms-block-1015375" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-1015375" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-1015375');
                        
                });
            </script>
        </div>
    </div>
</div><div id="tncms-block-685851" class="tncms-block"><section id="block-685851" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-685851 ">
        <div class="block-title-inner">
            <h4>
                
                Upcoming Events
                
            </h4>
        </div>
    </div></div>
    
        <ul class="card event-list">
        
	        <li id="card-event-list-21252dbc-c8fd-11e9-9cf5-6b7931db4c79" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">3</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/al-anon-group-to-meet-wednesdays-in-grangeville/event_21252dbc-c8fd-11e9-9cf5-6b7931db4c79.html" class="tnt-asset-link">
        

        
            Al-Anon group to meet Wednesdays in Grangeville</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-03T12:00:00-08:00">
            Wed, Feb 3, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-57bed8d2-c8fd-11e9-b52a-37647a518494" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">3</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/clearwater-meal-center-luncheon/event_57bed8d2-c8fd-11e9-b52a-37647a518494.html" class="tnt-asset-link">
        

        
            Clearwater Meal Center luncheon</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-03T12:00:00-08:00">
            Wed, Feb 3, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-96ee877c-9172-11e9-b815-4f062cea6951" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">3</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/walk-with-the-docs---orofino/event_96ee877c-9172-11e9-b815-4f062cea6951.html" class="tnt-asset-link">
        

        
            Walk with the Docs - Orofino</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-03T18:00:00-08:00">
            Wed, Feb 3, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-686217b2-65a5-11eb-8cce-8f8c4cca594b" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">4</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/usda-food-distribution-set-for-feb-4/event_686217b2-65a5-11eb-8cce-8f8c4cca594b.html" class="tnt-asset-link">
        

        
            USDA food distribution set for Feb. 4</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-04T10:00:00-08:00">
            Thu, Feb 4, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-72b18266-4fcf-11eb-9568-bbb97e55b50c" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">5</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/tournament-scheduled-feb-5-6/event_72b18266-4fcf-11eb-9568-bbb97e55b50c.html" class="tnt-asset-link">
        

        
            Tournament scheduled Feb. 5-6</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-05T00:00:00-08:00">
            Fri, Feb 5, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-140a0624-9172-11e9-b0e9-47ff11642a5d" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">5</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/walk-with-the-docs---ahsahka/event_140a0624-9172-11e9-b0e9-47ff11642a5d.html" class="tnt-asset-link">
        

        
            Walk with the Docs - Ahsahka</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-05T07:30:00-08:00">
            Fri, Feb 5, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-b520f974-65a5-11eb-a26f-2fc5abbb7dbf" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">6</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/ecwr-committee-will-meet-feb-6-in-clearwater/event_b520f974-65a5-11eb-a26f-2fc5abbb7dbf.html" class="tnt-asset-link">
        

        
            ECWR committee will meet Feb. 6 in Clearwater</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-06T11:00:00-08:00">
            Sat, Feb 6, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-49ff7bbe-554e-11eb-988b-e73f794477d4" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">7</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/clearwater-grange-bazaar-yard-sale-set-for-feb-7/event_49ff7bbe-554e-11eb-988b-e73f794477d4.html" class="tnt-asset-link">
        

        
            Clearwater Grange bazaar/yard sale set for Feb. 7</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-07T09:00:00-08:00">
            Sun, Feb 7, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-557b89a4-604a-11eb-ae05-639882968a72" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">9</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/blood-drive-on-tap-in-grangeville-for-feb-9/event_557b89a4-604a-11eb-ae05-639882968a72.html" class="tnt-asset-link">
        

        
            Blood drive on tap in Grangeville for Feb. 9</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-09T12:00:00-08:00">
            Tue, Feb 9, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-21252dbc-c8fd-11e9-9cf5-6b7931db4c79" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">10</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/al-anon-group-to-meet-wednesdays-in-grangeville/event_21252dbc-c8fd-11e9-9cf5-6b7931db4c79.html" class="tnt-asset-link">
        

        
            Al-Anon group to meet Wednesdays in Grangeville</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-10T12:00:00-08:00">
            Wed, Feb 10, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-96ee877c-9172-11e9-b815-4f062cea6951" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">10</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/walk-with-the-docs---orofino/event_96ee877c-9172-11e9-b815-4f062cea6951.html" class="tnt-asset-link">
        

        
            Walk with the Docs - Orofino</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-10T18:00:00-08:00">
            Wed, Feb 10, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-140a0624-9172-11e9-b0e9-47ff11642a5d" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">12</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/walk-with-the-docs---ahsahka/event_140a0624-9172-11e9-b0e9-47ff11642a5d.html" class="tnt-asset-link">
        

        
            Walk with the Docs - Ahsahka</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-12T07:30:00-08:00">
            Fri, Feb 12, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-fb902a4c-65a5-11eb-8f31-e7691f7f40be" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">12</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/bingo-set-for-second-fourth-fridays/event_fb902a4c-65a5-11eb-8f31-e7691f7f40be.html" class="tnt-asset-link">
        

        
            Bingo set for second, fourth Fridays</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-12T19:00:00-08:00">
            Fri, Feb 12, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-9eba517a-604c-11eb-a85e-5fa89fb14ec5" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">13</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/yab-offers-candygrams-for-valentine-s-day/event_9eba517a-604c-11eb-a85e-5fa89fb14ec5.html" class="tnt-asset-link">
        

        
            YAB offers candygrams for Valentine’s Day</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-13T00:00:00-08:00">
            Sat, Feb 13, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-62c5159c-6024-11eb-9a64-7fed0a356399" class="event-list-item  clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">13</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/valentine-s-dinner-at-kamiah-set-feb-13/event_62c5159c-6024-11eb-9a64-7fed0a356399.html" class="tnt-asset-link">
        

        
            Valentine’s dinner at Kamiah set Feb. 13</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-13T18:30:00-08:00">
            Sat, Feb 13, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
	        <li id="card-event-list-e9eef89a-6023-11eb-92b7-ffbe940fc351" class="event-list-item last clearfix  tnt-section-calendar">
	                <div class="event-date-square event-date-container">
	                        <span class="event-month">Feb</span>
	                    
	                        <span class="event-day">13</span>
	                    
	                </div>
	                <div class="event-info">
	                    
	
	                    <div class="card-headline event-title">
	                        <h4 class="tnt-headline ">
        
             <a href="/calendar/valentine-dinner-set-for-elk-city-feb-13/event_e9eef89a-6023-11eb-92b7-ffbe940fc351.html" class="tnt-asset-link">
        

        
            Valentine dinner set for Elk City Feb. 13</a></h4>
	                    </div>
	                    <div class="event-date">
	                        

    
        <time datetime="2021-02-13T19:00:00-08:00">
            Sat, Feb 13, 2021 
        </time>
        
	                    </div>
	                    
	                    
	                </div>
	            </li>
	            
	        
        
        </ul>
    </section></div></div><div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-893601" class="tncms-block"><div class="modal promo-designer-modal in centered " id="promo-designer-modal-custom-pop" tabindex="-1" role="dialog" aria-label="Promotional pop up" aria-hidden="true" >
        <div class="modal-dialog modal-md centered">
            <div class="modal-content">
                <div class="modal-body"><section id="block-893601" class="block emphasis-h3   " ><div class="promo-design"><div class="sticker circle">
            <span class="far tnt-newspaper"></span>
        </div><div class="card-bg-color rectangle">
        <div class="card-panel panel"><button type="button" class="close" data-dismiss="modal" aria-label="Close">
                <span class="tnt-stack" aria-hidden="true">
                    <i class="fas tnt-circle tnt-inverse tnt-stack-1x"></i>
                    <i class="fas tnt-times-circle tnt-stack-1x"></i>
                </span>
            </button>
             <div class="panel-body">
                <div class="promo-designer-wrapper">
                        <div class="lead-in dark text-shadow">
                            Your support is needed now more than ever
                        </div>
                    
                    
                        <div class="headline large dark ">
                            Help support your local news
                        </div>
                    
                    
                        <p class="text dark ">
                            Local news sources need your help. As a subscriber you'll stay in the know and help us continue our mission to keep the community informed.
                        </p>
                    <div class="promo-design-button">
                            <a href="https://www.idahocountyfreepress.com/site/forms/subscription_services/#utm_source=blox&utm_campaign=pop_up&utm_campaign_name=subscribe_promo_exit_layover&utm_medium=utility_promo_designer&utm_content=utility_promo_designer">
                                <button type="button" class="btn btn-primary btn-lg">Subscribe today</button>
                            </a>
                        </div>
                </div>   
            </div>
        </div>
    </div>
</div></section></div>
            </div>
        </div>
    </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-685940" class="tncms-block"><section id="block-685940" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-685940 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link  nav-home  tnt-section-home"  href="/"  tabindex="0">
                    <span class="nav-icon fas tnt-home tnt-fw"></span> <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link   tnt-section-news"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-community"  href="/community/"  tabindex="0">
                    <span class="nav-label">Community</span>
                </a></li><li>
                <a class="nav-link   tnt-section-obituaries"  href="/obituaries"  tabindex="0">
                    <span class="nav-label">Obituaries</span>
                </a></li><li>
                <a class="nav-link   tnt-section-milestones"  href="/milestones/"  tabindex="0">
                    <span class="nav-label">Milestones</span>
                </a></li><li>
                <a class="nav-link   tnt-section-opinion"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-multimedia"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Multimedia</span>
                </a></li></ul></div></div>
    <div id="footer-col-two" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-685891" class="tncms-block"><section id="block-685891" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-685891 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div><div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-submission-forms"  href="/site/forms/"  tabindex="0">
                    <span class="nav-label">Submission Forms</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li><li>
                <a class="nav-link   tnt-section-calendar"  href="/calendar/"  tabindex="0">
                    <span class="nav-label">Calendar</span>
                </a></li><li>
                <a class="nav-link   tnt-section-search"  href="/search/"  tabindex="0">
                    <span class="nav-label">Search</span>
                </a></li><li>
                <a class="nav-link   tnt-section-weather"  href="/weather/"  tabindex="0">
                    <span class="nav-label">Weather</span>
                </a></li><li>
                <a class="nav-link   tnt-section-subscribe"  href="/site/forms/subscription_services/"  tabindex="0">
                    <span class="nav-label">Subscribe</span>
                </a></li></ul></div></div>
    <div id="footer-col-three" class="col-md-4 col-sm-4"><div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-685942" class="tncms-block"><section id="block-685942" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-685942 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>idahocountyfreepress.com</strong><br>
    900 W Main St<br>
    Grangeville, ID  83530
    <br>
    
        <strong>Phone:</strong> 208-983-1200<br>
        <strong>Email:</strong> <a href="mailto:ifponline@idahocountyfreepress.com">ifponline@idahocountyfreepress.com</a><br>
    
</address></section></div><div id="tncms-block-685950" class="tncms-block padding-bottom"><div class="follow-links-685950 default">
    
    <section id="block-685950" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-685950 ">
        <div class="block-title-inner">
            <h4>
                
                Follow Us
                
            </h4>
        </div>
    </div></div><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/idahocountyfreepress/" title="Facebook" target="_blank" rel="noopener" class="btn btn-md btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.idahocountyfreepress.com",
  "sameAs" : ["https://www.facebook.com/idahocountyfreepress/"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-710829" class="tncms-block"><!-- Go to www.addthis.com/dashboard to customize your tools --><script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-55d6943e4b43f2d7"></script></div></div></div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-685895" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-685895"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">Idaho County Free Press</a>, 900 W Main St Grangeville, ID</small><small>&nbsp;| <a href="/site/terms.html">Terms of Use</a></small><small>&nbsp;| <a href="/site/privacy.html">Privacy Policy</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    <div id="sticky-anchor"><div id="tncms-region-page_sticky_anchor" class="tncms-region hidden-print collapse in"><div id="tncms-block-731045" class="tncms-block"><div class="tnt-ads-container text-center  " >
        <div id="ad-731045" class="tnt-ads dfp-ad" data-lazy="true" data-refresh="true" data-mobile-refresh="true" >
            <script>
                googletag.cmd.push(function() {
                        googletag.display('ad-731045');
                        
                });
            </script>
        </div>
    </div>
</div></div></div>
    <!-- / site-container close -->
    </div>
    
    
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("b3d8ee22-6286-11eb-82b1-43c8a113ada8")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                _cc13590.add('act', dmpData);_cc13590.bcp();
            });
        });
    
    </script>
    
    
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/metering/resources/scripts/tnt.metering.c1fd4b9015c14b57a58acdbc3ee4daca.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.core.050324358012800e91ac7e9936c6d6d9.js"></script>
<script src="https://az412349.vo.msecnd.net/pio/pio.latest.v2.js"></script>
<script>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</script>
<script>/*<![CDATA[*/ 
    document.addEventListener("DOMContentLoaded", function() {
        updateCartCount();
        var cartLinks = document.querySelectorAll("a.open-cart");
        for (i = 0; i < cartLinks.length; i++) {
            cartLinks[i].addEventListener("click", function (e) {
                e.preventDefault();
                gooten_photo_collection.unshift( "data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAEAAAABCAQAAAC1HAwCAAAAC0lEQVR42mM8Uw8AAh0BTZud3BwAAAAASUVORK5CYII=");
                PIO.open({ 
                    goTo: "cart",
                    images: gooten_photo_collection
                });
                document.getElementById("__pio").src = "https://widget.print.io/widget/b4309023-78ee-487b-9112-58da8835bacb/";
            });
        }
    }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/withinviewport.1f94ee79a22e6ee8e9c0bb61dec9999b.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.withinviewport.6ef0fee1774e9b313c264a5736522e35.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/jquery.scrollstop.934c2bd4d6bebe0494bcb9dd4b1b6ca1.js"></script>
<script>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</script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/bulletins.29b98144dea96166607cf028fe68b7e2.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/promo_popup.fe40d77fce691e6ed54cb520a782a693.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/idahocountyfreepress.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.regions.54d9f15b0d238de6bb20ec82ed8307ac.js"></script>
<script>/*<![CDATA[*/ __tnt.regions.stickyAnchor.init(); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            jQuery(document).ready(function($){
                var iqLogin = Cookies.get('tnt-iq-login') || false;
                if (__tnt.user.loggedIn && iqLogin == false) {
                    if (__tnt.user.services) {
                        var userServices = __tnt.user.services.split(',');
                        for (i = 0; i < userServices.length; i++) { 
                            var serviceData = 'has_subservice: ' + userServices[i];
                            _cc13590.add('act', serviceData);_cc13590.bcp();
                        }
                    }
                    Cookies.set('tnt-iq-login', 1);
                }
            });
        
            if (window.location.hash){
                var hashSet = ['tncms_source','utm_source','utm_campaign','utm_medium','utm_content','utm_term'],
                    urlHash = window.location.hash.replace('#','').split('&');
                for (var i = 0; i < urlHash.length; i++) {
                    var data = urlHash[i].split('='),
                        param = data[0].replace('-','_');
                    if (hashSet.indexOf(param) != -1){
                        var dmpData = param + ': ' + data[1];
                        _cc13590.add('act', dmpData);_cc13590.bcp();
                    }
                }
            }
         /*]]>*/</script></body>
</html>